Can not install household module

Hello, everyone! I have a question. The household module does not appear in the Administration page when I add it. So where is it ? I saw a picture on google, like this. image

I used OpenMrs Core 2.2.0, household-1.0.2-SNAPSHOT.omod

@vietnam001 when you click on Manage Modules , do you happen to see it there up and running ?

Can you try to build install it using this If you found it on google better to try building yourself and explore that nice experience :grinning: you can as well follow this link for guidance

@sharif @gcliff when I click on Manage Modules. I saw it there. It runs fine, not error. I installed it using this GitHub - openmrs/openmrs-module-household: OpenMRS Household Module. But it had some errors, I fixed it… Now I don’t know where household module is to see UI like this

I have one more question Is OpenMrs Core 2.2.0 compatible with household module 1.0.3SnapShot ?

here is my problem link youtube:

yes it is according to the settings in the module config.xml file


Which errors can you share the error logs

For you to be able to access household-module, you will first build it, personally am trying to look through it in more details ,am however looking into this log,

1 Like


it seems this was solved but we can reopen it later for the current fix

Hello , i have been able to run it successfully without skipping test, try upgrade > org.apache.maven.plugins


and >


Then try building it again without skipping tests. though am still not sure why its failing to run in standalone

If you are still debugging, this may be of help unable to find module activator. we will need to add some dependencies in config.xml file as suggested in the link i provided in the link here.

thanks you! Finally, it was able to display on the on administration page. I had to change the settings in the module config.xml file

<!-- <require_version></require_version> -->


  <require_module version ="1.5.0">org.openmrs.module.legacyui</require_module>

<!-- Extensions -->
1 Like

Thats very good, am sure you are now ready to go, Are you ble to access its UI on patientDashboard page like the screenshot you provided last above

@sharif oops, It still exists errors, I’m trying to look through it in more details,

here log:

same problem here

can you share that log after trying to access configuration on it here So we have internal server error, btw This message indicates that an error has occurred during connection to the server and that the requested page cannot be accessed

1 Like

Yes,I fixed it through this post .

It seems that the interface is too different from this interface in wiki page???

Yeah its kinda different because the first ui was old i saw it was reproduce 6yrs ago, thats the same ui page i also got after running it. thanks for keeping on this :+1:

oh, many thanks you, too :rofl: :rofl:

1 Like