Build failure when trying to watch a module on an SDK instance.

So what was the problem?

Well, I can’t a firm why am failing to watch appointmentschedulingui module on RefApp 2.10 though I can watch other modules. I tried installing bower though I suspected bower failed because the components directory was stale and being the first timer I abandoned it and instead installed RefApp 2.11 which is working perfectly well. That makes conclude the is a bug(which needs quality time to be identified) to be fixed for one to be able to watch appointmentschedulingui on RefApp 2.10.

@dkayiwa, @gcliff and @gcliff I have confirmed appointmentschedulingui module can be watched on RefApp 2.10. The prior build failure was my mistake. After fixing a bug on registration module, I forgot to unwatch this module by running mvn openmrs-sdk:unwatch. This incidence leaves me with a question: Does it mean 2 or more modules cannot be watched at the same time?

i dont think its possible because you were trying to watch two modules on the same server , it might be possible(though not sure coz i have never tried it out in a particular usecase) if its on different servers

You should be able to watch more than one module at the same time.

If that is the case, then am failing to understand why I couldn’t watch the two modules at the same time. Anyway, that is not end of discovering and trying out new things.

Has anyone come a cross this error while trying to watch module-coreapps ?

Connection reset looks like a network connection problem. Try again.

I have tried watching the coreapps module again but this is the error am getting https://www.nicepaste.com/yMspSTBDOJ

What happens when you unwatch and run again?

When I unwatch the coreapps module then run the server a fresh it builds successfully.

Are you able to successfully watch other modules?

Oh sorry for the late response. I have successfully watched reporting module and appointment module

Do you have any local changes in the coreapps module?

No. I haven’t made any changes.

And does mvn clean install succeed for the latest snapshot version of the coreapps module?

When I run mvn clean install after cloning the coreapps module repository, this is the error I run into http://hastebin-plus.herokuapp.com/4dApggnw4S

The paste link returns a blank page.

You are right and am sorry for the mess. I’m trying to use pastebin to share the entire error log but am still facing a challenge

Pastebin’s SMART filters have detected potentially offensive or questionable content in your paste. The content you are trying to publish has been deemed potentially offensive or questionable by our filters, because of this you’re receiving this warning. This paste can only be published with the visibility set to "Private".

I have tried hastebin but still am failing . Kindly how do I go about?

simply go here,https://pastebin.com/ paste the logs and click the create new paste button down then share the link here