Bahmni installation failure in centos

Greetings! I am trying to install bahmni 0.89 in CentOS 6.8 I have confronted this error

Your help please!

not sure this could help

(I passed openerp installation but have a problem with bahmni-lab installation)

Thanks Zacrify! I have used your clue and the installation seems completed, but i at last when i want to login in browser i get this page

Down for maintenance
Sorry for the inconvenience, we understand that this could be impacting patient care.

    Please re-visit in a few minutes!

@mfugale You crashed some how like me.


yum list installed | grep bahmni`

to see that all bahmni services were installed or not. (section “Figuring out which RPM versions of Bahmni are installed”)

I’m not an IT guy myself but my problem seem to cause by bahmni installer not install all of services.

Dear Zacrify! Thanks for your suppot, I have succeeded to install bahmni, I can access only openerp and emr(openmrs), but i cant access openelis. I don’t know what went wrong. I have tried bamhni install command again to no avail.

after running the command yum list installed | grep bahmni I get the following

Your help will be highly appreciated! Thank you for your time and patience with me.

I have the same problem as yours. no bahmni-lab service installed.

I tried to install bahmni-lab service but the bahmni lab won’t appear neither.

maybe have to wait for the team to look at this problem…

Hey! Have you gotten any clue for the above problem for installing bahmni-lab in bamhni 0.89

hi @mfugale I tried to followed the step from Binduak here(bahmni-lab not start after install bahmni!!!) but still not work. Maybe you can tried step from here bahmni-lab not start after install bahmni!!! and see if it work out or not.

Hi @mfugale I tried to followed step from Binduak again and it’s work

Great! I have to follow these steps too. what changes did you apply then

first you shoud checking log in


to see whether your openelis has this error or not

nohup: failed to run command/usr/java/jre1.8.0_101/bin/java’: No such file or directory`

if yes go to


inside bahmni-lab.conf should be like this

# required by embedded tomcat as env variables
export SERVER_PORT=8052
export BASE_DIR=/var/run/bahmni-lab
export CONTEXT_PATH=/openelis
export WAR_DIRECTORY=/var/run/bahmni-lab/bahmni-lab
export SERVER_OPTS="-Xms512m -Xmx1024m -XX:PermSize=256m -XX:MaxPermSize=512m"
export DEBUG_OPTS="-agentlib:jdwp=transport=dt_socket,address=8001,server=y,suspend=n"
export JAVA_HOME=/usr/java/jre1.8.0_101


-change JAVA_HOME=/usr/java/jre1.8.0_101 to JAVA_HOME=/usr/java/jre1.8.0_131

-start bahmni-lab service again

this work for me.

OK. I am trying this . I will let you know the output

Thanks you zacrify!. I have tried you option and it works now. I Can access openelis now.

Dear @zacrify Can you help this. In Bahmni I can’t find a page where I can add or remove the wards(for admitting patients), there are two wards only with their respective beds but I don’t know where I can’t add/edit/remove them Thanks in advance

Hi I’m not really sure about that. maybe you can create a new topic for your question.