Bahmni homepage error

Hello all, I’m still new to bahmni just set it up today and all went well in the installation on Digital Ocean.

all functions are working fine except the Bahmni Home page, it gets stuck on the dashboard, even thought I already activated the service on my digital ocean.

when i viewed the console errors it shows this:

Failed to load resource: the server responded with a status of 503 (Service Temporarily Unavailable) Ex.js

But when I click on that link it shows up that the server is Down for maintenance.

Please help me with this issue, if any further details required let me know.


nevermind, I sorted it out… but now another problem happened, whenever I go to the I get the down for maintenance screen.

I’ve been tinkering for a while now, thanks to google :frowning:

Hi @fares, Try doing service httpd reload. I guess, that must be the issue.

@fares how did you solve your
503 (Service Temporarily Unavailable) Ex.js” error?

I am getting a similar (or the same) one when trying to open Bahmni (

DELETE 503 (Service Temporarily Unavailable).

I installed Bahmni on CentOS 6.9 following this instructions and configured the firewall as described here. In addition I changed the SSH port.

Does someone know how to solve this?

Thanks in advance!

Okay, I solved this. Maybe it is interesting for anybody getting the same error:

I was checking /var/log/openmrs/openmrs/log which stated: failed to run command /usr/java/jre1.8.0_101/bin/java': No such file or directory

However, jre’s version on my server was jre1.8.0_131. Thus, I removed my jre with $ yum remove jre and installed jre1.8.0_101 as described here:

  1. login to your server
  2. $ cd /opt
  3. $ wget
  4. $ yum install jre-8u101-linux-x64.rpm
  5. $ service openmrs restart
1 Like