Xreport issues with rendering pdf

Hello @dkayiwa,

I’m having some issues with the xreport module. After i finish creating the report and choosing xreportpdfrenderer as the renderer, i’m not able to have to view the pdf file. if i open it in the browser, it’s blank and if i download it and try to open it, it says that the file is damage but i’m able to view the report when i choose web preview as the renderer.

Same thing when i use xreport in the reference application. The rendering is blank.

First i thought the problem was coming from the fact that it was a custom report based on an sql dataset, but it’s the same issue with the built-in reports.

Do you or anyone has any idea?


Can you share the server side log via pastebin.com?

here is the log. it seems like nothing is being logged except for one report that i’m having trouble running. but that has nothing to do with the main problem.

One more thing. when i run a built-in report that has parameters from xreport in the reference app, i have this page

Did you design the report layout in the xreports designer?

1 Like

no i did not know i have to. i have tried to design it but i did not really understand how it works and what the documentation i found on the wiki did not help much. it was just explanation of the menu.

First of all, do you have a mockup or screenshot of what your report should ultimately look like?

well it’s nothing complicated. it’s just a table that will display all the results.

Do you have a screenshot of how that data looks like in the web preview?

and all the report will have this layout. just a table and probably the report label at the top of the table.

After clicking the XReports manage reports button and select this report, have you selected the source of this report? Or can i look at a screenshot?

yes i chose the source and everything, i even went to the designer but once inside the designer i don’t really know what to do. i try to design a table using the table tool but i’m only having the first line of the result. i dont know how to make the table dynamic.

Drag those two Design Items and drop them on the empty report page. Then save and test again.

only one line is displayed

Under Design Items, double click each of the two items and on the window that pops up, select X Pos after Data Type. Then save and test again.

1 Like

Yes it’s working now. Thank you

Now how can i design a table around it since i cannot guess the number of row in advance

Right click to add a table of two rows and two columns. Then drag and drop those two design items into the respective columns. Save and test again.

1 Like

Thank you @dkayiwa, it’s working fine. Now i have another issue. i have created an sql dataset with parameters

When i click on preview i get the report to work but when i run it i have this error:

and at the same time when i try to run it in the xreport module i get this:

it looks like it’s not recognizing the parameters syntax

Can you also paste the sql query in pastebin.com?