Working on Issue MF434

When I was trying to start a dev server using command npx openers debug —run-project, the command was stuck in the middle for a whole night. Here is the pastebin. zoe@zoe-VirtualBox:~/openmrs-esm-primary-navigation$ npx openmrs debug --run-pro - Can anyone please help me?

The simplest approach to solve this is by deleting the entire project, do a fresh clone then:

npm i

npx openmrs debug

We can use the channel #microfrontend to discuss details, share files, and get work done. Join here: the squad is more active over there

Hi Herman, I tried to delete the packages and clone repository from scratch by the command still got stuck at a point. I have asked the question in Microfrontend’s slack channel. Here is the pastebin message zoe@zoe-VirtualBox:~/openmrs-esm-primary-navigation$ npx openmrs debug --run-pro -

I see Project is running at http://localhost:8081/ in your pastebin paste. What is displayed in your browser when you open via http://localhost:8081/

The error clearly shows that the address localhost:8080 is already in use. Maybe something else is running in the background.

I hope this helps you out.

1 Like

I tried to run with a different port 1234, and I think it helps me to bypass the port error. Here is the pastebin message zoe@zoe-VirtualBox:~$ npx openmrs debug --run-project --port 1234Need to insta - But for the new error, the webpage says: The solution is to make your dependency chain update to source-map-resolve version 0.6.0 or later, or switch to dependencies not using source-map-resolve at all. However, I am not sure how to achieve that.

this can be a network error.

Hi Herman, after some troubleshooting, the command led me to the localhost:1234/openmrs/spa/ website, but it told me unable to connect. Should I run some commands before starting the dev server? like the database?

Which command could you be refering to @zoe ???

I believe the database doesn’t need to be started. If you have got an internet connection, the application should be able to start at the specified localhost address. You need an internet connection because of the API calls involved.

The command is : npx openmrs debug --run-project --port 1234

I do have Internet connection. I am not sure what is causing that problem.

It should start the dev server. What happens when you run that command

it led me to this url localhost:1234/openmrs/spa/ , and the webpage could not be loaded. It said unable to connect.

Paste your terminal results here after running the command

zoe@zoe-VirtualBox:~/openmrs-esm-primary-navigation$ npx openmrs debug --run-pro - here is the pastebin message. Thank you!

I dont know if setting the node options helps like Here !

Cc :@grace / @ibacher / @samuel34

I tried the command and got compiled successfully. this webpage showed up file:///home/zoe/openmrs-esm-primary-navigation/node_modules/@openmrs/esm-app-shell/dist/report.html. I am still not able to open the localhost:8080/openmrs/spa/login page.

@zoe If you’re still running it with the --port 1234 flag, then http://localhost:8080/openmrs/spa/login will not work, but you should be able to use http://localhost:1234/openmrs/spa/login.