Why home page on devtest01 was changed?

Why home page on devtest01 was changed?

I can see that actually no module has started, even the reference application module - probably that is why it looks the way it looks. What is going on??

I suspect it’s an issue with the reporting module. The version 0.9.5 was released yesterday and the distro build started to fail. I’ll try changing the version to 0.9.6-SNAPSHOT.

The error message: Error while trying to start module Unable to load/find moduleActivator: ‘org.openmrs.module.reporting.ReportingModuleActivator’ Module: Reporting

@mseaton, any clues?

I seems that changing to 0.9.6-SNAPSHOT fixed the issue. I haven’t investigated why it failed for 0.9.5.

1 Like

Yeah, this seems like it is my fault. I did a release yesterday, but was having issues with the maven release plugin, so uploaded the release artifacts to Nexus manually. I believe that the issue is likely that, for the omod project, I uploaded the web jar rather than the full omod. This will be true for htmlwidgets as well.

I tried tracking down instructions for what needs to be done manually in order to replicate the mvn deploy step, but couldn’t find anything on the wiki. Particularly: https://wiki.openmrs.org/display/docs/Maven+Release+Process and https://wiki.openmrs.org/display/docs/Managing+the+Maven+Repository

I’ve gone in and deleted the bad artifacts from Nexus. Next step is to release new ones. I’ll bump up the version so as to eliminate inconsistencies with local maven repositories. Is there a best practice as to whether I should upload new, correct artifacts for the bad releases, or leave them deleted?

For future reference, what is the right process for manually uploading artifacts? Would it be correct to rename the built omod so that it has a “.jar” extension, and upload that?

Thanks, Mike

On a side note, did you try releasing from bamboo? https://wiki.openmrs.org/display/docs/Releasing+a+Module+from+Bamboo

FWIW, compiling openmrs-distro-referenceapplication fails locally despite pulling the latest changes.

My guess is that is because I just released reporting 0.9.6, and now 0.9.6-SNAPSHOT does not exist, and the openmrs-distro-referenceapplication pom references 0.9.6-SNAPSHOT.

Is this supposed to use the maven versions plug-in to update the pom automatically? Did that not work correctly in this case? Or is someone actually supposed to go in and manually update this each time?

Thanks, Mike

I remember as if this would be automatically taken care of if you released from bamboo.

And the release to maven bamboo build variable being “refapp.distro.property” with value “reportingVersion”

I had forgotten we had this set up on CI when I did the release yesterday. This morning, when I had to do a new release, I tried from CI and it bombed out, using what seemed like the wrong version number. I know there is a place where you can set build variables when you kick things off, but there isn’t much guidance on what should be included there. Is there documentation around this?

1 Like

The maven.release.version variable in the reporting module build is currently set to 0.9.5. As we are now at 0.9.7-SNAPSHOT, should we update the variable to 0.9.7 and then do another release (via CI this time)?

Usually it’s usually pretty painful to upload anything more than a simple jar manually. I’d usually recommend avoiding it and getting the release plugin working, it’s usually better as you get all the pieces together.

My guess is that is because I just released reporting 0.9.6, and now 0.9.6-SNAPSHOT does not exist, and the openmrs-distro-referenceapplication pom references 0.9.6-SNAPSHOT.

Correct, nexus is configured to delete snapshots of released dependencies.

The doco should be in https://wiki.openmrs.org/display/docs/Releasing+a+Module+from+Bamboo, it’s linked on the build description too.