Why can't I add a Tomcat user when installing OpenMRS on Mac?

Platform Version: 1.11.3

I am installing OpenMRS on Mac and got stuck on the tomcat section.

sudo useradd tomcat6
Error: sudo: useradd: command not found

I am not sure what i am doing wrong. Please help Thanks

Hello @kenny60612,

This is not a issue at OpenMRS end but the useradd command is not recognized. I think the link provided should be of help.

Thanks. this is what i got $ dscl . -create /Users/tomcat6 main> attribute status: eDSPermissionError <dscl_cmd> DS Error: -14120 (eDSPermissionError)


try using the command with a sudo

Yes i have tried: sudo useradd tomcat6 sudo

also tried sudo with create. Did not work

Hello @kenny60612,

I am not a Mac user so I am not entirely sure what it is you need to do differently. But for tomcat installation and configuration, I guess this guide is written in clear steps. I haven’t tried it, but I hope this might help. https://code.google.com/p/gbif-providertoolkit/wiki/TomcatInstallationMacOSX

@kenny60612 my recommendation is to use Homebrew for installing Java, Tomcat and MySQL on the Mac, it will truly make your life easier http://brew.sh/

You can follow the steps on this guide https://wiki.openmrs.org/display/docs/Installation+for+Developers+on+Mac+OS and be patient as you may need to try 2-3 times due to various issues

Thanks a lot. i started the install but got stuck here

Kenny-iMac:code Kenny$ cd ./openmrs-core Kenny-iMac:openmrs-core Kenny $ mvn clean install -bash: mvn: command not found

Any ideas ?

This suggests Maven is not installed, or installed incorrectly. Did you specifically install it first?