Visit Notes Page Fails after uploading module

I’m developing a module for OpenMRS 2.2 that uses the UI Framework. My module seems to be working, but when I upload it, it causes the Visit Notes page to fail.

In 2.2 (core 1.11.4), when you attempt to submit a Visit Note, it fails with this trace: In 2.1 (core 1.10.2), simply navigating to the Visit Notes pages from the patient dashboard fails with this stack trace:

This doesn’t seem to be the result of my code directly. I tried uploading a simple starter module generated by the SDK (omrssdk-1.0.7) with a service layer and admin page, but no modifications, and I was met with the same errors.

I have gotten these errors on both MacOSX Mavericks running off of Eclipse/Jetty as well as Ubuntu 14.04 with Tomcat6.

Does anyone know what is causing this and how to solve/work around it?


1 Like

It’s a strange behavior. Does restarting the server after you install a module help? Does the same thing happen when you use 2.2 standalone, which you can get from

Turns out that restarting the server resolves the issue. But that’s now an unfortunately installation step: Install module, restart server.

I am getting the same error using the 2.2 standalone, restarting the server fixed this as well.

Thanks for the help!

Is your code public? A restart shouldn’t be required, especially if you just generated a module and made small changes.