Unknown issues doing the initial build of the openmrs-core


(Nicolas McCabe) #1

I am having an issue when trying to build the project. These are the instructions I am following: https://wiki.openmrs.org/display/docs/Getting+Started+as+a+Developer#app-switcher I am on step 5, set up your development environment. I follow these instructions to get the code: https://wiki.openmrs.org/display/docs/Using+Git using git bash Then once I get everything downloaded / cloned I run “mvn clean install” from inside the outermost folder in the repo. It gets through to the tests and it fails.

“Failed to execute goal org.apache.maven.plugins:maven-surefire-plugin:2.18.1:test on project openmrs-api”

On top of all this I did have it built awhile ago so I am not sure why I can’t get it to build anymore. I had everything setup and just had to install a UI module. That is when I messed up because I wasn’t sure which module I should be using for development. I was told Legacy UI Module but when reading through the comments it seemed that the legacy UI module was meant for version 2.0.x and not anything else.

Any assistance you could give on why I might be having these build issues or which UI module I am meant to be using would be great. My intent is to work on either of the following two tasks:

or

Any help would be greatly appreciated.


(Daniel Kayiwa) #2

Can you share the entire build log at pastebin.com?


(Nicolas McCabe) #3

Here you go: https://pastebin.com/UQEYxNHr


(Daniel Kayiwa) #4

In your folder path, remove the space between “OpenMRS Workspace” and then compile again.


(Nicolas McCabe) #5

That worked, thank you very much. Follow up question: Should I be developing using the Legacy UI Module or is there a different one that is best used?


(Daniel Kayiwa) #6

Aren’t you the one who asked this? Confused about UI Module setup


(Nicolas McCabe) #7

Yes, I forgot about that post as it was helpful, but I misread and didn’t see that you mentioned that the intro issue would point me to the modules needed to complete work on the task.