# Unable to update data model using liquibase.xml. Module: HTML Form Entry

**URL:** https://talk.openmrs.org/t/unable-to-update-data-model-using-liquibase-xml-module-html-form-entry/14838
**Category:** Implementing
**Tags:** html-form-entry, liquibase
**Created:** [December 26, 2017, 6:47pm UTC](https://talk.openmrs.org/t/unable-to-update-data-model-using-liquibase-xml-module-html-form-entry/14838 "2017-12-26T18:47:05Z")
**Posts on this page:** 9
**Page:** 1

<div class="post-metadata">

### Author: ![engr.riyad](https://talk.openmrs.org/letter_avatar/engr.riyad/32/5_5575768a8748004e209b776fc1b2916d.png) [@engr.riyad](https://talk.openmrs.org/u/engr.riyad)
#### Post date: [December 26, 2017, 6:47pm UTC](https://talk.openmrs.org/t/unable-to-update-data-model-using-liquibase-xml-module-html-form-entry/14838/1 "2017-12-26T18:47:06Z")

</div>

Dear Concern, I’m facing a critical issue.

I’m facing a disgusting issue and bored with frustration . My organization using openmrs 1.8 . Now everyone decide to upgrade it 2.05 . I upgraded it and I saw many tables structure changed on DB. But after upgrading I tried to enable “HTML form entry” module. But it gives error “Error while trying to start module Unable to update data model using liquibase.xml. Module: HTML Form Entry” . How can I solve it? Without “Html Form Module” openmrs is useless for me.

Openmrs version: 2.05 Tomcat: 8 Java: 8 Mysql: mysql Ver 14.14 Distrib 5.7.20, for Linux (x86\_64) using EditLine wrapper

---

<div class="post-metadata">

### Author: ![dkayiwa](https://talk.openmrs.org/user_avatar/talk.openmrs.org/dkayiwa/32/179_2.png) [@dkayiwa](https://talk.openmrs.org/u/dkayiwa)
#### Post date: [December 26, 2017, 7:47pm UTC](https://talk.openmrs.org/t/unable-to-update-data-model-using-liquibase-xml-module-html-form-entry/14838/2 "2017-12-26T19:47:49Z")

</div>

Can you paste the tomcat logs at [pastebin.com](http://pastebin.com)?

---

<div class="post-metadata">

### Author: ![engr.riyad](https://talk.openmrs.org/letter_avatar/engr.riyad/32/5_5575768a8748004e209b776fc1b2916d.png) [@engr.riyad](https://talk.openmrs.org/u/engr.riyad)
#### Post date: [January 4, 2018, 4:19pm UTC](https://talk.openmrs.org/t/unable-to-update-data-model-using-liquibase-xml-module-html-form-entry/14838/3 "2018-01-04T16:19:48Z")

</div>

Hi, I solved this problem. But I’m facing another issue. I tried to update from 1.9.2 to 2.1.2

During Database upgrade, its shows:

```
??? Reason: liquibase.exception.DatabaseException: Error executing SQL ALTER TABLE `cohort_member` ADD `start_date` DATETIME NOT NULL: Data truncation: Incorrect datetime value: '0000-00-00 00:00:00' for column 'start_date' at row 1:???
Unable to update the database. See server error logs for the full stacktrace.
???There was an error while updating the database to the latest. file: liquibase-update-to-latest.xml. Error: Migration failed for change set liquibase-update-to-latest.xml::201609171146-3::vshankar:???
??? Caused By: Error executing SQL ALTER TABLE `cohort_member` ADD `start_date` DATETIME NOT NULL: Data truncation: Incorrect datetime value: '0000-00-00 00:00:00' for column 'start_date' at row 1:???
??? Caused By: Data truncation: Incorrect datetime value: '0000-00-00 00:00:00' for column 'start_date' at row 1???

```

My database 5.7.2 version. I also disable full group by using this tutorial:

> <https://stackoverflow.com/questions/23921117/disable-only-full-group-by>

Can you please give me quick answer. My administration decide to migrate 2.12 version. We have 80000 patients and 3300000 observation.

Screen shot: [https://unsee.cc/ef5cb2f0/](https://unsee.cc/ef5cb2f0/)

[https://unsee.cc/3457ed9e/](https://unsee.cc/3457ed9e/)

---

<div class="post-metadata">

### Author: ![dkayiwa](https://talk.openmrs.org/user_avatar/talk.openmrs.org/dkayiwa/32/179_2.png) [@dkayiwa](https://talk.openmrs.org/u/dkayiwa)
#### Post date: [January 4, 2018, 7:09pm UTC](https://talk.openmrs.org/t/unable-to-update-data-model-using-liquibase-xml-module-html-form-entry/14838/4 "2018-01-04T19:09:38Z")

</div>

Try executing this sql statement:

UPDATE cohort\_member SET start\_date = NULL WHERE start\_date \< ‘0000-01-01 00:00:00’

Then continue with the upgrade.

---

<div class="post-metadata">

### Author: ![engr.riyad](https://talk.openmrs.org/letter_avatar/engr.riyad/32/5_5575768a8748004e209b776fc1b2916d.png) [@engr.riyad](https://talk.openmrs.org/u/engr.riyad)
#### Post date: [January 6, 2018, 8:00am UTC](https://talk.openmrs.org/t/unable-to-update-data-model-using-liquibase-xml-module-html-form-entry/14838/5 "2018-01-06T08:00:39Z")

</div>

Hi, I created same table structure, but after run upgrade showing this error:

```
??? liquibase-update-to-latest.xml : Not precondition failed???
??? Caused By: Preconditions Failed???
???There was an error while updating the database to the latest. file: liquibase-update-to-latest.xml. Error: Migration failed for change set liquibase-update-to-latest.xml::201610042145-1::vshankar:???
Unable to update the database. See server error logs for the full stacktrace.
??? Reason: ???
???:???
```

---

<div class="post-metadata">

### Author: ![dkayiwa](https://talk.openmrs.org/user_avatar/talk.openmrs.org/dkayiwa/32/179_2.png) [@dkayiwa](https://talk.openmrs.org/u/dkayiwa)
#### Post date: [January 6, 2018, 8:11pm UTC](https://talk.openmrs.org/t/unable-to-update-data-model-using-liquibase-xml-module-html-form-entry/14838/6 "2018-01-06T20:11:21Z")

</div>

Did you run the sql statement that i gave above?

If yes, can you paste the log at [pastebin.com](http://pastebin.com)?

---

<div class="post-metadata">

### Author: ![engr.riyad](https://talk.openmrs.org/letter_avatar/engr.riyad/32/5_5575768a8748004e209b776fc1b2916d.png) [@engr.riyad](https://talk.openmrs.org/u/engr.riyad)
#### Post date: [January 29, 2018, 9:03am UTC](https://talk.openmrs.org/t/unable-to-update-data-model-using-liquibase-xml-module-html-form-entry/14838/7 "2018-01-29T09:03:56Z")

</div>

Again I tried to upgrade openmrs from 1.9.2 to 2.1.2 in “Test installation” mode. Please see the video, I’m getting this error.

Is there any way to solve this issue?

Also two error on log:

ERROR - TestInstallUtil.addTestData(105) |2018-01-29 15:04:24,535| mysql: [Warning] Using a password on the command line interface can be insecure. ERROR 2006 (HY000) at line 4414 in file: ‘/tmp/tomcat8-tomcat8-tmp/testDataSet5274836228896457710dump’: MySQL server has gone away ERROR - TestInstallUtil.addTestData(116) |2018-01-29 15:04:24,536| The process terminated abnormally while adding test data. Please look under the Configuration section at: [https://wiki.openmrs.org/display/docs/Release+Testing+Helper+Module](https://wiki.openmrs.org/display/docs/Release+Testing+Helper+Module)

---

<div class="post-metadata">

### Author: ![dkayiwa](https://talk.openmrs.org/user_avatar/talk.openmrs.org/dkayiwa/32/179_2.png) [@dkayiwa](https://talk.openmrs.org/u/dkayiwa)
#### Post date: [February 1, 2018, 9:23pm UTC](https://talk.openmrs.org/t/unable-to-update-data-model-using-liquibase-xml-module-html-form-entry/14838/8 "2018-02-01T21:23:54Z")

</div>

Are you choosing the Test Installation mode because you just want to get some demo data?

---

<div class="post-metadata">

### Author: ![engr.riyad](https://talk.openmrs.org/letter_avatar/engr.riyad/32/5_5575768a8748004e209b776fc1b2916d.png) [@engr.riyad](https://talk.openmrs.org/u/engr.riyad)
#### Post date: [February 19, 2018, 10:31am UTC](https://talk.openmrs.org/t/unable-to-update-data-model-using-liquibase-xml-module-html-form-entry/14838/9 "2018-02-19T10:31:55Z")

</div>

Solved. Its need mysql 5.7.2
