Am testing the new Emr-api module whether it can Migrate existing diagnosis data captured via the emrapi module from the obs table to the encounter_diagnosis. i get this error. wea am i supposed to start changing??
Which exact version of openmrs-core are you running?
am running the snapshot version 2.2.0 which implements the Diagnosis Service
If i wanted to reproduce this error, what are the exact steps?
wen i try to look at the log, it sims the error is not related to the commits to do with data migration from obs to encounter-diagnosis table but rather with conditons table
set up an sdk server which runs on platform version 2.2.0 snapshot.
add in the reference app modules…
Start the server
so i actualy got that error right with the latest released version of emrapi…not necesairly the snapshot version ive compiled
Isn’t it easier to just run the sdk again and choose “Distribution” for the second step and then a distribution of interest, instead of having to manually add the reference application modules?
ya but , the problem is wen i choose distribution, i may not be able to specify the platform version am intrested in.
the last time i choose distribution and selected ref app 2.8, i was supried that it was running on platform 2.06. yet am more intrested in the platform version
but its fine, let me , simply set up another server , that uses a distribution. ill give u the feed back
am downloading dependencies for ref app 2.9.0 snapshot … but i can see here its going to run on platform 2.1.3… wc am not intrested in. thats y i chose …platform at first…coz there i know i have control over the platform version
Can you compile the openmrs-core war file to replace that one of the SDK?
i have done that, it has not returned a data model error, but their are many apps not starting because of others
every module is saying is not starting because of the other… these things of…
“adam y did u eat the fruit…” …“because of eve”
“eve y did u eat” …" the snake that u ceated"
so am failing to get which module exactly “ate the fruit”
Just click the start all button.
well it still doesnt solve it
appFramework says needs " webservices.rest 2.21.0"
reportingRest need “webservices.rest 2.5”…
Now in the modules folder i see
and in the modules list on the under “manage modules”… i cant see it.
in the addons , the latest version for Rest Web Services is 2.22.2
now how can the reportingRest module recquire a version of webservices.rest wc doesnt exist
What is in the logs?
actually it sims , its “webservices.rest” that brings the whole problem. now y cant i see it in the module list under “manage modules”…yet i can see it in the modules folder??