Unable to find openmrs-runtime.properties

I am trying to deploy an openmrs war file in web apps folder of apache-tomcat-8.5.54 using mysql 5.7,but it looks like the openmrs-runtime properties file cannot be created as per the logs,https://pastebin.com/TpKFHN6t I have tried out with different mysql versions i.e 5.5, and still the error persists.I do have my mysql instance running at 3306. i have tried on platform 2.3 and snap shot 2.4,and i use java:

openjdk version “1.8.0_252” OpenJDK Runtime Environment (build 1.8.0_252-b09) OpenJDK Server VM (build 25.252-b09, mixed mode). I have also tried out a couple of suggested fixes but all in vain,any suggestion on fixing this cc @dkayiwa @ibacher @mksd

Caused by: java.sql.SQLException: Access denied for user 'root'@'localhost' (using password: NO)

at my root,i have a password and its what i use to login to the mysql instance

same error on mysql 5.6

Delete everything including AppData openmrs contents and do fresh installation. clear appropriate caches and try again.Otherewise you will spend forever there.

Look into the Permission issue as well.

1 Like