Unable to download metadatamapping jar from maven repositories for any of the available versions (1.0 to 1.4.0))

[ERROR] Failed to execute goal on project bacteriology-api: Could not resolve dependencies for project org.openmrs.module:bacteriology-api:jar:1.3.0-SNAPSHOT: Could not find artifact org.openmrs.module:metadatamapping:jar:1.3.4 in openmrs-repo (JFrog) → [Help 1]

<dependency>
	<groupId>org.openmrs.module</groupId>
	<artifactId>metadatamapping</artifactId>
	<version>1.3.4</version>
</dependency>

@ibacher @dkayiwa

Change the artifactId from metadatamapping to metadatamapping-api as below:

<dependency>
	<groupId>org.openmrs.module</groupId>
	<artifactId>metadatamapping-api</artifactId>
	<version>1.3.4</version>
</dependency>
2 Likes

Thanks a lot! It is now working