unable to create openmrs-runtime.properties file after redeploying openmrs

Share a screenshot with the contents of your modules folder.

Here is the modules folder with its contents. Modules folder content

Stop tomcat, delete the log files. Start tomcat and send me the new log.

Here is the new log file. user interface error4 - Pastebin.com

Could not start some modules because they depend on others which are not started. Please first start them or use the "Start All" button on the "Manage Modules" page: [fhir->legacyui] org.openmrs.util.CycleException: [fhir->legacyui]

Do you have the fhir module any where?

I have remove all modules I only have legacyui modules on modules folder. I have fhir2 somewhere should I copy it to openmrs folder modules?

I do not expect to see the fhir module any where in the logs. At least for now. Can you check the bundledModules folder of your expanded war file to see if it has any modules?

where is bundledModules folder located?

Check under tomcat’s webapps/openmrs/WEB-INF

Yes it is here :/var/lib/tomcat7/webapps/openmrs/WEB-INF/bundledModules$ lsfhir-1.20.0.omod . Should I delete it?

Yes delete and restart openmrs.

I still don’t get the user interface. user interface error5 - Pastebin.com

Do you still have the legacyui module in the modules folder? Delete the tomcat work folder and restart openmrs. The share the full log.

I did get a different error .Openmrs error 1 - Pastebin.com

Do you get the same error if you restart tomcat?

Yes i still get the same error after restarting openmrs.

Can you share the full log via pastebin.com?

Here is the log file. Openmrs error 2 - Pastebin.com

Stop tomcat, delete this folder /var/lib/tomcat7/work/Catalina and then start tomcat again.

The folder /var/lib/tomcat/work is not available because I have deleted it. I still receive the same error