Unable to add uiframework 3.8 to OpenMRS core source code


(Rushikesh Chaudhari ) #1

I cloned the openmrs core source code from github ,it successfully compile and build but after the initial set up i.e. downloading demo data and other stuff it give me the error,

ModuleFactory.startModules(256) |2019-02-13 16:40:55,601| Module UI Commons Module cannot be started because it requires the following module(s): uiframework 3.8 Please install and start these modules first.

Same error I also got when I install referenced module 2.2 , that time I downloaded legacyui.omod and copy that in omod folder. But for eclipse, I don’t understand what to do.Please suggest me some solution.


(Daniel Kayiwa) #2

Can you start by sharing the full log at pastebin.com?


(Rushikesh Chaudhari ) #3

Hey I pasted full log : pastebin.com/0JXJWzv7


(Nathan Ruhanga) #4

@rushikesh , what would you like to achieve as you install openmrs? Depending on your desire, you may want to install and deploy openmrs using the OpenMRS SDK or simply install and use the OpenMRS standalone version . Otherwise there are several dependencies to resolve step by step as you install individual modules on a fresh openmrs-core instance as the error indicates.


(Daniel Kayiwa) #5

Did you put your modules in this folder? C:\Users\user\Application Data\OpenMRS\modules


(Rushikesh Chaudhari ) #6

Actually I want start to learn how contribute to the OpenMRS ,so I cloned core in eclipse.Is there any other way to contribute to OpenMRS ?


(Rushikesh Chaudhari ) #7

There are no such folder created in my PC


(Daniel Kayiwa) #8

Which folder?


(Rushikesh Chaudhari ) #9

C:\Users\user\Application Data\OpenMRS\modules


(Daniel Kayiwa) #10

Try check for the location of your runtime properties file along these lines: https://wiki.openmrs.org/display/docs/Overriding+OpenMRS+Default+Runtime+Properties