UI Framework Error while accessing the manageApps .page with the sdk


(Herbert Yiga) #1

in relation to this ticket, https://issues.openmrs.org/browse/RA-923 , i am required to set up a manageExtensions page while refering to the manageApps.page.I have set up the openmrs sdk and now trying to access the manageApps.page using this link http://localhost:8080/openmrs/referenceapplication/manageApps.page in relation to the ticket description.But i get an error to do with the uiframework as seen here.https://hastebin.com/ukikinoyug.rb will be grate full on any suggetion about solving the error


(Nathan Ruhanga) #2

@herbert24, can you manage to login based on location then land to the home page? If so, then you can try this option [System Administration -->Manage Apps] to arrive to the Manage Apps page.


(Herbert Yiga) #3

@ruhanga have loged in successfully, i moved to the administration page and by clicking on the manageApps page i go to http://localhost:8080/openmrs/module/owa/manage.form but not the manageApps.page!!


(Nathan Ruhanga) #4

@herbert24, are you running or did you install reference application distribution? You should be having a home page similar to this

from where you can then access the System Administration icon in order to access Manage Apps icon.


(Samuel Male) #5

In the first place, which reffApp version are you running?

And just for troubleshooting purposes, are all the vital reference application modules started?


(Herbert Yiga) #6

absolutely no,sorry i cant upload the interface that i was having because i am re installing the sdk,let me get back to you after


(Nathan Ruhanga) #7

Do opt for the latest version that comes first on the options of available distros to install.


(Herbert Yiga) #8

okie then thanks


(Herbert Yiga) #9

@ruhanga this is the home interface i get after installing distro,reference application version 2.9 snapshot! it was the same when i installed 2.8,now i want to try 2.7


(Nathan Ruhanga) #10

Looks strange though. Version 2.9 SNAPSHOT worked just fine for me. You may most likely need to start or restart all the installed modules via Administration tab then under the Modules option, hit Manage Modules to confirm all the modules required were installed and if so restart or start them using the Start All button. BTW Openmrs demo is now working great. You may want to access it.


(Herbert Yiga) #11

hello, i finally solved this. I had to delete the apparent appframework 2.1.chmod module within my sdk and replaced it with appframework 2.9.chmod.After i had to restart the sdk and was able to access the manageApps page as i wanted.i did this on reference application 2.9 snap shot .Thanks for the support @ruhanga