Troubleshooting getting started as a dev

Hi! As a newbie i want to install OpenMRS, can anyone guide me on these procedures. i have tried out without success

Which of the installation steps failed for you and what was the error? Are you trying to get started as a developer or an implementer?

1 Like

i have failed with maven. i want to try to get started as a developer or both if its possible

What was the command you ran and what was the error message?

1 Like

First of all, Iam using a manual installation option, and my platform is ubuntu 12.04

maven installed now. then when i issue the command "mvn jetty:run " it carries on some changes but finally http://localhost:8080/openmrs .is not working

In order to help you, we will need to see the full Maven output. Please upload it to something like pastie.org and share the link here.

1 Like

Alright when i run “mvn jetty:run” i get the following http://pastie.org/private/k2mlkcair1kr4khbfjjxlg

1 Like

Based on the first couple of Google results, this is a permissions issue. Do you see the same error if you run from your home directory, or if you use sudo?

1 Like

At last when i try “localhost:8080/openmrs” i get the following snapshot

That is the Tomcat 404 screen. Do you want to use Tomcat, or do you want to use jetty (by running mvn jetty:run)?

Okay! Then tomcat would better i think

1 Like

So, this suggests that, jetty is not installed right?

Okay, then just build the OpenMRS WAR file:

mvn clean install

Then copy the resulting openmrs.war file to the Tomcat webapps directory:

cp /path/to/openmrs.war /var/lib/tomcat7/webapps/

Then restart Tomcat:

sudo service tomcat7 restart

Then visit http://localhost:8080/openmrs again.

You can also watch the Tomcat log while OpenMRS is starting up to make sure there are no errors:

sudo tail -f /var/log/tomcat7/catalina.out

No, the error is that Maven doesn’t have permission to create the /var/lib/OPENMRS/openmrs-core/webapp/target/classes directory.

1 Like

It failed when downloading a jar from openmrs maven repo. It can be circumstantial, try it again.

http://mavenrepo.openmrs.org/nexus/content/repositories/public/org/openmrs/web/openmrs-web/2.1.0-SNAPSHOT/openmrs-web-2.1.0-20160419.074017-83.jar (160 KB at 39.1 KB/sec) Apr 19, 2016 11:37:35 PM org.apache.commons.httpclient.HttpMethodDirector executeWithRetry **

INFO: I/O exception (org.apache.commons.httpclient.NoHttpResponseException) caught when processing request: The server mavenrepo.openmrs.org failed to respond

**

2 Likes

Hey I have been off for a while . Iam back. So i need to give persmission to the Maven, can you point me the right location.Iam using ubuntu

I still can’t figure about how it works to install. Please check then with snapshot.