There seems to be a backward incompatibility in hibernate versions

Tags: #<Tag:0x00007f0774036308>

yes @irenyak1

It still brings an error.

Is it the same error?

This is the error log @dkayiwa and @mozzy

How about version 4.3.11.Final?

still it is not compiling. Errorlog @dkayiwa

Are you sure that you are using version 4.3.11.Final? I would not expect a compiler error. At least a unit test failure but not compiler error.

I have surely used 4.3.11.Final but it is still failing yet before changing to that version I did git pull --rebase upstream master. Here is the error log

I don’t really know why this build is failing :thinking:

How about 4.3.10.Final?

@dkayiwa, Here is what i get when i use 4.3.10.Final, error log

Can you point me to the lines of code that you changed?

here is the line. in my eclipse it is line 1050

<hibernateVersion>4.3.10.Final</hibernateVersion>

That should compile fine. Can you do a pull request to see if travis will also fail?

Alright let me do that straight away.

@dkayiwa I have pushed into the existing PR. TRUNK-5499-upgrade-hibernate-libraries #2949 and This is the commit https://github.com/openmrs/openmrs-core/pull/2949/commits/5865cd11cc5b4b7a78baf4a571aa263b9727d60a

That pull request has more changes than a mere change of version that am asking for.

@dkayiwa so should I just make another pull request or I point you to the commit?

@dkayiwa from your post, do I have to make a PR with only this change ? Then do i have to take back the versions of the other libraries first to test if

<hibernateVersion>4.3.10.Final</hibernateVersion> 

works fine?

Hello @dkayiwa using <hibernateVersion>4.3.10.Final</hibernateVersion> works fine and the build is success on my local machine . Still waiting for the travis build. Please may you review my PR here

As I wait for the travis build let me be updating the other sub libraries also.

Thank you very much.

Hello @dkayiwa I have updated these and they are successfully building

<hibernateVersion>4.3.10.Final</hibernateVersion> 

and

<dependency>
		<groupId>org.hibernate</groupId>
		<artifactId>hibernate-validator</artifactId>
		<version>6.0.16.Final</version>
</dependency>

However,

<dependency>
		<groupId>org.hibernate</groupId>
		<artifactId>hibernate-search-orm</artifactId>
		<version>5.2.0.Final</version>
</dependency>

Is still failing with this error. I am still trying with other versions.