There seems to be a backward incompatibility in hibernate versions

Hello developers, I am working on this ticket and I have updated these sub libraries as follows
org.hibernate:hibernate-c3p0 … 4.3.9.Final → 5.4.2.Final

org.hibernate:hibernate-core … 4.3.9.Final → 5.4.2.Final

org.hibernate:hibernate-ehcache … 4.3.9.Final → 5.4.2.Final

org.hibernate:hibernate-search-orm … 5.1.2.Final → 5.11.1.Final

org.hibernate:hibernate-validator … 4.2.0.Final → 6.0.16.Final

However, when I run (mvn clean install ) the build fails giving me this error

Here is the full log after running mvn clean install -X it could not be created in pastebin because of it’s size the limitations that pastebin gives to different users. error logs.pdf (350.3 KB)

I think the issue is about backward incompatibility in the hibernate versions. Please may you guide me on this.

cc @dkayiwa , @k.joseph , @ssmusoke @mozzy , @ruhanga and all the community.

Does 5.1.0.Final compile successfully?


What could this be for among all the versions above?

Looking for the newest version that compiles successfully.

Let me try it out @dkayiwa

@dkayiwa still I get an error with 5.1.0 Final, however this time I get this warning

[WARNING] The artifact org.hibernate:hibernate-validator:jar:6.0.16.Final has been relocated to org.hibernate.validator:hibernate-validator:jar:6.0.16.Final

which I thought would be the cause of the error.

I went ahead and replaced the core pom and api pom with these




respectively, but still the build does not pass. Here is the error log after applying the above changes

I have updated with the newest version however the build still fails locally. On the remote repo it is only the travis CI which is still failing @dkayiwa. Here is my PR

How about 5.0.0?

@dkayiwa are you meaning I use 5.0.0 for the hibernate version?

@dkayiwa are you meaning I use 5.0.0 for the hibernate version?

1 Like

yes @irenyak1

It still brings an error.

Is it the same error?

This is the error log @dkayiwa and @mozzy

How about version 4.3.11.Final?

still it is not compiling. Errorlog @dkayiwa

Are you sure that you are using version 4.3.11.Final? I would not expect a compiler error. At least a unit test failure but not compiler error.

I have surely used 4.3.11.Final but it is still failing yet before changing to that version I did git pull --rebase upstream master. Here is the error log

I don’t really know why this build is failing :thinking:

How about 4.3.10.Final?

@dkayiwa, Here is what i get when i use 4.3.10.Final, error log