Tests failing locally and after making the PR.

Hello all, we are updating the libraries on this link https://issues.openmrs.org/secure/RapidBoard.jspa?rapidView=201 but after updating the dependencies with the latest version, some tests fail to build locally and some after building successfully locally, the travic CI fails after making the pull request. What could be the course and possible solution?

CC @odorajonathan

3 Likes

could you drop the pr link for this here!

Just a moment I have made some changes am trying to run again.

1 Like

@jwnasambu your being too generic :thinking: .
like “we” , “updating the dependencies”.
I dont think its a general case really like the way you have put it up :smiley: Because we have closed several tickets where libraries have been upgraded succesfully.

can you try to be specific on which ticket/dependence have you got issues on ??

@mozzy I think @jwnasambu used we because we both have some build failures upgrading some of the libraries like in this Pull Request, she could as well list her PR so it can be looked at too.

Don’t really know why the Travis fails even after upgrading the library’s dependencies as well.

1 Like

I have worked on all the tickets not claimed on this link and are failing locally.

Really? . Have you tried cleaning your M2/Repository folder and building afresh per library?? try adding a -U option on the maven command to force update of dependencies

Cleaning the .m2 directory would be painful for those with a slow connection or not enough data. Can you list the pull requests with this problem? Did you also look and analyse the failure logs?

1 Like

@dkayiwa This is my Pull Request with build failures both locally and on github https://github.com/openmrs/openmrs-core/pull/2914 also tried comparing versions and their dependencies for the libraries relating to the failure logs, didn’t yield as much either.

@odorajonathan

try adding add an explicit dependency of powermock-core in the POM: like

<dependency>
    <groupId>org.powermock</groupId>
    <artifactId>powermock-core</artifactId>
    <version>2.0.2</version>
    <scope>test</scope>
</dependency>
1 Like

@odorajonathan try adding that dependence and and see if it works

1 Like

@dkayiwa and @mozzy this is the pull request with failures both locally and on github https://github.com/openmrs/openmrs-core/pull/2934/commits/17adfea0c9f35fbf7f46230920a9cd418b27d430. I have tried different versions all in vain.

can you share the logs??

This is the error log. https://pastebin.com/k3MR2ANB

@jwnasambu, have you tried to google around??

Yes I have done it and tried different releases but all in vain