Stuck at Maintenance Mode after uploading demo data

I am facing an issue while trying to run OpenMRS after uploading demo data into the database. I’ve tried using the WAR file from the website for 2.0.1, as well as downloading the core-master repo and building it using mvn. Both have the same result. I would appreciate some help into how I can get past this screen and get to use OpenMRS.

I’d be happy to upload any of the logs.


Try wiping the database and starting over? Also, what DBMS? What version?

Tried that, didn’t work.

MySQL: 5.7.17 OpenMRS: 2.1.0-Snapshot (Compiled yesterday) Apache: 7.0.75

What demo data did you upload? (e.g. what’s the url you downloaded it from)

I downloaded the demo data from the OpenMRS Wiki itself. The set for for 2.0.1. (

I haven’t tried this myself, but I would suggest trying again with the released 2.0.1 war and the 2.0.1 demo data, and report the exact error for that scenario.

Isn’t it strange that from the screenshot it says that you’re running OpenMRS 2.1.0 not 2.0.1 and actually 2.1.0 isn’t yet released.

@setu4993 , Hope you’re using legacy UI and not the reference app as this demo data is not compatible with the reference application.

I tried it again, but I changed the sequence of execution a little. After the initial installation, I loaded the demo data. After which, I copied the LegacyUI module and reloaded the application from Apache. This seems to have done the trick. Previously, I tested the LegacyUI and started it before loading demo data into the MySQL database. For some reason, it seems to break things.

For now, it is working.

@wyclif : My understanding is that it says 2.1.0 because I was using the Snapshot version. Correct me if I’m wrong.

@reubenv : Yes, I have been Legacy UI module.

Installing 2.0.1 brings me to another problem, which was the reason I tried the core-master in the first place. The calculation module loads but doesn’t start. And because of this, a few other modules that are dependent on the calculation module, don’t work either.

I think right there is the reason why you were running into issues, you can’t keep joggling between different OpenMRS versions against the same DB, it’s a recipe for problems.

1 Like

I understand that. Which is why I cleared all of the previous installation data before installing a new one, each time.

I couldn’t run any of the reporting modules on 2.0.1, because the calculation module refused to start, which is why I tried building and installing from the core-master build. However, the core-master ran into different issues and didn’t let me access demo data.

Right now, after installing 2.0.1 afresh, the demo data is loaded, but I cannot install the calculation module, and thus cannot use any of the other modules that I wish to.

Which version of the calculation module are you using?

Tried Calculation 1.2 and building 1.3-Snapshot from the Github repo, both. Neither works.

Simply saying that Neither works is not helpful enough for us to help. You need to give the failure details.

Sorry about that.

When the module is loaded, it says ‘Module loaded and started successfully’, but it hasn’t actually started. In the list below, it shows up with a green start button. When I press that button, it says ‘Error while starting module calculation’. The same error occurs when I try it with Calculation 1.3-Snapshot, built from the Github repo.

Can you paste the contents of the logs at

Here’s the log file from the OpenMRS folder, from when I tried to add the Calculation module with the web interface.

In your database, do you have the “calculation_registration” table?