[Solved] Error on building open web app

On building a fresh copy of open web app using mvn clean install, i run into G:\openmrs\modules\openmrs-module-owa>mvn clean installPicked up _JAVA_OPTIONS - Pastebin.com Any suggestions on fixing this? cc @dev3 @dev4 @dev5

According to the error logs

install_rightDownloadUrl(org.openmrs.module.owa.web.controller.OwaRestControllerTest) Time elapsed: 1.094 sec <<< FAILURE!

java.lang.AssertionError: expected:<owa.app_installed> but wa null

There is an assertionError committed with in this commit OWA-59: Display more explicit error message on owa upload failure (#67) · openmrs/openmrs-module-owa@93837cb · GitHub

cc @ruhanga could throw some more light on this , otherwise i think the fix should the rectify the assertion error on line 93 incase @herbert24 you are trying to fix it .

thanks @sharif fixed this, am gona make a pr in a few seconds

1 Like

pull request CB-216:Fix breaking tests on building by HerbertYiga · Pull Request #73 · openmrs/openmrs-module-owa · GitHub