snapshot version issue

Tags: #<Tag:0x00007fa3ecf3ac18>

Hi, I successfully installed Open MRS on my local machine. I was also able to access the database on my MySQL server. However, I had no interface installed. I tried to rerun the jetty server and bumped into the following startup issue. Any fixes might help out. Thanks!

Can you pull the latest changes to update your code and try again?

Yes. I will try doing that.

I tried doing the same after updating my code. However, I get the same issue.

What does this command return? git reset --hard

It returns the following:

HEAD is now at e2344f895 Trunk-5739:Expand updateOrderFulfillerStatus to also set accession number (#3202)

Start by doing an mvn clean install. Then run again and send the log via pastebin.com

1 Like

here you go: https://pastebin.com/Fvhu7i5k

Not what you see in the browser. But the server side log.

my bad https://pastebin.com/ANJh1a6u

If the original one was your bad, the one you have just sent is your baddest. :smile:

I dont really understand which server side log should i post. should i post the entire log?

https://pastebin.com/b4fmBxc4

Yes this is the correct log. Can you drop your openmrs database and run again?

This is what the sever log displays:

https://pastebin.com/jV66k1NL

And on the browser:

https://pastebin.com/w7LbV1LA

Can you delete your runtime properties file too and run again?

Thank you for your help, I can now initialize the database once again. however, I did that last time successfully and at the end of the step it said I had no interface module installed. I followed the steps in the following link:

https://wiki.openmrs.org/display/docs/User+Interface+Modules

After downloading the legacyui module, while copying the .omod file, I checked my local data i could not find an OpenMRS folder. do you know what could be the issue?

The application data folder is reported in the log. If you can share the log, i can tell you where that is.

Here is the log:

https://pastebin.com/u1P6P1jm

You need to first run the setup wizard in your browser.

The log is too big. It mainly shows all the database queries that it executes. How am I suppose to share it here?