Setting Up Reference Application for Development


(Sai Kiran Varikooty) #1

Hi All, I am trying to set up a developer reference application environment. I have followed the wiki pages and here are the steps I am doing:

  1. Start MySQL 5.6 server and have a database created
  2. Forked and cloned the openmrs-core repository and ran “mvn clean install” with success
  3. Forked and cloned the openmrs-distro-referenceapplication repository and ran “mvn clean install” with success
  4. Copy the omod files from “…\openmrs-distro-referenceapplication\package\target\distro\web\modules” to folder “…\AppData\Roaming\OpenMRS\modules” folder
  5. Run “mvn jetty:run” in openmrs-core\webapp folder.
  6. Open “http://localhost:8080/openmrs/” in my browser.

I can see the page with “…If you are seeing this page, it means that the OpenMRS Platform is running successfully, but no user interface module is installed…”

Here is the jetty server log:

https://pastebin.com/gr99PZ0x

Could someone let me know if I am missing or doing any steps incorrectly?

Appreciate the help!

Regards, Sai


(Reuben Varghese) #2

Hi @svariko,

It looks like your modules aren’t loaded. I’m not really sure about the steps for windows (since I use Linux) and as to what may be wrong ,but since I guess you’re setting it up for development, you may want to try OpenMRS SDK


(Daniel Kayiwa) #3

Can you tell us the full path of where your “openmrs-runtime.properties” file is?


(Sai Kiran Varikooty) #4

Thanks for the replies.

@reubenv I also tried using the OpenMRS SDK but I had some issues with that as well, I’ll try that again maybe I missed something.

@dkayiwa Here’s the path to the file: “C:\Users\skv\openmrs-core\webapp\openmrs-runtime.txt”


(Daniel Kayiwa) #5

Delete that file, run again, and then share the log.


(Sai Kiran Varikooty) #6

@dkayiwa Hi Daniel, I deleted the file. But now I am unable to connect to my MySQL database. I’m using a nonstandard port of 3307 to run the server instead of the default 3306 since I have a later version of MySQL installed running a server on the default port already. Is there a way to specify this without the “openmrs-runtime.txt” file?


(Daniel Kayiwa) #7

Can you share the failure log?


(Sai Kiran Varikooty) #8

Here’s the log: https://pastebin.com/qvrAQ7d3


(Sai Kiran Varikooty) #9

Also as an update I was able to install the reference application using the OpenMRS SDK.

I’m not sure why it didn’t work earlier. Thanks for the help. The steps above still have the error as in the log in the previous post.

Is using the openmrs-sdk a preferred way of development setup? I’m looking to get started so just exploring currently, no specific use case in mind.


(Samuel Male) #10

Hey!

As a matter of fact that you aren’t using the default mysql port, can you update yr connection url in C:\Users\skv\Application Data\OpenMRS\openmrs-runtime.properties about your port and try again?