Running openmrs-sdk gives log4j error.

I installed openmrs-sdk reference application. I created a basic module and run the sdk using mvn openmrs-sdk:run but it gives error as:

log4j:ERROR A "org.apache.log4j.xml.DOMConfigurator" object is not assignable to a "org.apache.log4j.spi.Configurator" variable. log4j:ERROR The class "org.apache.log4j.spi.Configurator" was loaded by log4j:ERROR [ClassRealm[plugin>org.openmrs.maven.plugins:openmrs-sdk-maven-plugin:3.13.4, parent: sun.misc.Launcher$AppClassLoader@7d4991ad]] whereas object of type log4j:ERROR "org.apache.log4j.xml.DOMConfigurator" was loaded by [WebappClassLoader context: /openmrs delegate: false repositories: /WEB-INF/classes/ ----------> Parent Classloader: ClassRealm[tomcat, parent: null] ]. log4j:ERROR Could not instantiate configurator [org.apache.log4j.xml.DOMConfigurator].

How to solve this error?

Did you get a chance to look at this ? Did you tried with mvn clean install openmrs-sdk:run ?

yes, I did

Can you provide the full log using link

This looks familiar. Which version of the reference application did you set up? And how did you create the basic module?

The openmrs version is 2.3.0 with the Reference application version is 2.10.0 and I created the basic module using the command mvn openmrs-sdk:create-project.

And if the openmrs server is Distribution, should the module be Reference application?

Should the version of the openmrs and the module that we create should be same? The default module version support is 1.11.6.

Was it a Platform or Reference Application module?

It is the reference application module.

Do you still get that error after removing the FHIR Module?