run the SDK with changes

Tags: #<Tag:0x00007f01bff0d5f8>

Hi,

Been working on this ticket and this is my PR. I want to have the changes reflected on the database and on openrmrs. I seem not to succeed doing that. I started by running mvn clean install and then mvn openmrs-sdk:run to start the sdk though the changes aren’t reflected on the database or the refapp

Need some help going round this. @ruhanga @dkayiwa

On this page: https://wiki.openmrs.org/display/docs/OpenMRS+SDK did you see this?

If you execute the run command from a directory with a module or openmrs-core project, it will be automatically deployed before starting up the server. You can add the following run configuration to the IDE to build, deploy and run the project: mvn clean install openmrs-sdk:run -DserverId=myserver

4 Likes

@odorajonathan you can still manually replace the existing war file in the sdk server directory with the one you have newly built with your changes,

and the restart the sdk server. after doing that , you’ll share the server logs here

2 Likes

@odorajonathan still,to view the changes,you can build .omod file for the module on which you worked on,then deploy this to the modules folder within the sdk,then start up the sdk

Hi @dkayiwa running the command on the IDE has been resulting to this ERROR am not sure what it is, i wonder if the problem is with my sdk

I tried replacing the war file C:\Users\Admin\openmrs\server openmrs-2.1.4.war in the server folder with the war with that from the core folder under C:\Users\Admin\core\webapp\target openmrs.war, has a build failure while trying to start the sdk with the command mvn openmrs-sdk:run

Have you tried to run openmrs as instructed here? https://wiki.openmrs.org/display/docs/Step+by+Step+Installation+for+Developers

https://pastebin.com/8vGnLjrr while running openmrs using jetty. Here is a screen snapshot

1 Like

Drop the database and run the set up again.

1 Like

I have dropped DB root and any previous databases that were created yet reaching the updating database level while preparing the database it fails, am not taken to the welcome page or openmrs is not running. Here is a server side pastebin

Which version of MySQL are you running?

mysql version 5.7.8-rc-log

Can you upgrade to at least MySQL version 5.7.16?

1 Like

@dkayiwa trying to run the same as you requested at github, I get the following browser side pastebin error. This is the server log for the full output.

It says ERROR - MarkerIgnoringBase.error(159) |2019-07-17 13:57:46,412| Failed to obtain JDBC connection To solve it, I wonder if deleting the already existing folder containing OpenMRS’ preferences (under C:\Users\Admin\AppData\Roaming\OpenMRS ) and try to run the server again might solve this. Need some guidance here

1 Like

You are running it on a database different from the one you used before. You can drop the database, delete the runtime properties file, and run afresh.

1 Like