Rollback in Metadata Sharing

@raff what could be the cause of this

I’m sorry I have no idea. Do you have any more logs?

Ok. From the logs it shows everything to have been imported well but at the end, it gets a rollback. Or maybe I have an issue in the package itself

I tried importing via the MDS interface and could read this on the log

“NOT” in the concept name is recognized as a lucene keyword. It was fixed in

Either upgrade openmrs-core or add “NOT” to concept stop words list from the administration page.

Ok. Thanks for this. Am currently on 1.11.5, do I need a higher version than this? or which 1.11.x branch was back ported to?

The issue says it was fixed for 1.11.7.

@ningosi you can always check the Fix Version/s for the ticket.

Ok got it. Would anyone know the reason my import cannot complete, this is the error obtained from logs and it is being thrown at this point @raff

Is it compulsory for all concepts to have description? check and yet the table structure all null for description

My recollection is that starting with Platform 1.10, it’s required for every concept to have at least one description. (I don’t know if this is relevant here.)

It could be relevant. So description is more information about the concept, i.e describing more? I tried exporting all my non retired concepts though provided description for every concept but still getting this Is description in this context different from what I understand? line 113 and 120. Any thoughts why that is happening?

You possibly have a concept or two, that you forgot to give a description. Try exporting a smaller set of concepts to narrow it down, or simply cross check the descriptions of the concepts you are exporting, including descriptions of their answer concepts, for those that have.

Thanks @dkayiwa. Now how can someone tell what is causing the problem when they get this Has anyone ever gotten into that situation and managed to get out? @raff @dkayiwa @ssmusoke @darius @pascal

Do you mind sending the full stack trace? It would also be helpful to tell the exact versions of the module and platform that you are running.

This is the much I can get from logs Am running openmrs version 1.11.5 and metadata sharing version 1.2.0

Is this all that the log file contains? What is the name of this log file? Do you also get the same problem on using the latest version of the module? (1.2.2)

I just copied part of the catalina.out file starting from where the error emerge. I tried MDS version 1.2.2 and still get the same error

Can i look at the stack when using the latest version?