REST: Unable to load module messages error when starting

i recently installed OpenMRS enterprise edition on Ubuntu server, actually i’m trying to upload cashier module, i read Wiki according to wiki, says you need first configure in order to upload module, but when i try to click then it gives me an error saying An error has occurred!

The following error happened somewhere on this page: org.openmrs.api.APIException: A user context must first be passed to setUserContext()…use Context.openSession() (and closeSession() to prevent memory leaks!) before using the API

(The full error stack trace output is in the source of this page.)

So what is the correct procedure to upload module, ? thanks.

It’s not exactly clear how you encountered this problem. Can you provide some exact step-by-step instructions so others can re-create the problem to better understand it?

Also, please let us know what version of OpenMRS or Platform you downloaded & installed. Thanks! :smile:

Thankks Michael for quick response ;

I have installed 1.Platform 1.11.3 WAR (for Enterprise), actually i wanted to upload module So the problem i’m encountering is i can not upload module, because of error .

i just went through Wiki to resolve this issue, i found there in wiki , first needs to configure, so i tried to open that link it is giving me an error.

and also i have tried to upload module it is giving me an error saying internal error has occur. i have share snapshot of some error please review these snapshot thanks.

hi @michael

thank you very much for your effort, finally i could figure it out myself " this is all because of permission issue " after changing permission on .opemMRS directory then it started work.

thanks @michael

1 Like