Reporting Module

Application Name: Others - Reporting Module Version Number: 2.0.1

Question: I have successfully installed the Reporting module from github and uploaded it do the OpenMRS webapp. However, whenever I try to add parameters, or a new dataset definition, the pop-up is blank. I tried installing the logic module and the reporting compatibility module, and it still doesn’t work. What could the cause be? See image below.

What version of the reporting module? What version of the platform? Are you able to reproduce it here? uat-refapp.openmrs.org

Reporting module version: 0.10.7-SNAPSHOT OpenMRS version: 2.0.1

No I can’t reproduce it at uat-refapp.openmrs.org. I don’t think the XReports works just like the Reporting module. There is no reporting module installed in the apps.

@zachraduban on the uat-refapp server, did you check this? http://uat02.openmrs.org:8080/openmrs/admin/index.htm

1 Like

@dkayiwa Thank you! The reporting module works on this link. I can finally try out the reporting module. However, I still wish to be able to run the reporting module on my own localhost.

@zachraduban can you paste your tomcat log at pastebin.com?

@dkayiwa Using the uat-refapp server, I tried to create my own custom report following the steps indicated here https://wiki.openmrs.org/pages/viewpage.action?pageId=19300405, and I had successfully added parameters and dataset definitions, however, whenever I click preview, this shows up.

This is the full error: http://pastebin.com/8c6tU0Fx