RefApp 2.11.0 TESTING SPRINT - 1 Begins !

@sharif, I am interested in participating but wasn’t able to attend the QA meeting earlier today. Would love to learn the details on how to participate.

1 Like

@sharif it will be nice :grinning: if we can have a brief summary of the meeting :smile:.

1 Like

Hi @sharif this is great. I am sorry I was out of the town for 2 days I will join with you :smiley: .

1 Like

@achilep @ayesh @rainbow , we always have qa meetings on tuesday sorry for those who missed but let me hope testing is in progress

Thanks @sharif. Let me see how best to participate.

1 Like

Am trying to get started with qaframework but I get this error https://pastebin.com/rb13Tsw0 . What could I be missing here

[ERROR] Failed to execute goal on project qaframework: Could not resolve dependencies for project org.openmrs.contrib:qaframework:jar:1.0-SNAPSHOT: Failure to find org.openmrs.distro:referenceapplication-ui-tests:jar:tests:2.10.0 in http://mavenrepo.openmrs.org/nexus/content/repositories/public was cached in the local repository, resolution will not be reattempted until the update interval of openmrs-repo has elapsed or updates are forced -> [Help 1]

1 Like

What causes the INFO: Detected dialect: W3C during selenium tests. it happens and the tests fail with an exception

please attach the entire log

is the sprint in jira? here are a few tickets to get started with

2 Likes

when I run a Login.feature as cucumber feature i get this: https://pastebin.com/K0wBdVP4

so I did the mvn clean install and it failed with this error:https://pastebin.com/mjY5r75J

On the attachments feature, there is no prompt to make any attachment. could this be an issue to handle!

cc @sharif @k.joseph

Thanks @insookwa, You may be trying different way add an attachment. can you help us with procedures for us to reproduce to confirm

I just clicked on the attachment feature on the registered patient

@insookwa After registering a patient, you need to first start a visit under General Actions , The attachment file upload is always disabled until you start a visit.try again and confirm

1 Like

Awesome. It works as expected. thanks @sharif

1 Like

I have been getting this error when I do mvn clean test
C:\Users\Insookwa\openmrs\openmrs-contrib-qaframework>mvn clean testJava Hot - Pastebin.com on openmrs-contrib-qaframework\

how can I get rid of it @k.joseph @sharif

Are you still blocked with this, i see you have been unblocked here :wink:

it worked but failing with a new error from the solved one

please ensure to share the entire logs in a text readable format

I had used pastebin for the error here https://pastebin.com/4Dbn9eCX it also here in text form

C:\Users\Insookwa\openmrs\openmrs-contrib-qaframework>mvn clean install
Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=512m; support was removed in 8.0
[INFO] Scanning for projects...
[INFO]
[INFO] ------------------< org.openmrs.contrib:qaframework >-------------------
[INFO] Building OpenMRS QA Framework 1.0-SNAPSHOT
[INFO] --------------------------------[ jar ]---------------------------------
[INFO]
[INFO] --- maven-clean-plugin:2.5:clean (default-clean) @ qaframework ---
[INFO] Deleting C:\Users\Insookwa\openmrs\openmrs-contrib-qaframework\target
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time:  8.710 s
[INFO] Finished at: 2020-10-09T13:50:09+02:00
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-clean-plugin:2.5:clean (default-clean) on project qaframework: Failed to clean project: Failed to delete C:\Users\Insookwa\openmrs\openmrs-contrib-qaframework\target\chromedriverlogs\chromedriver-ConditionsSteps.log -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException