Publishing Forms

Reference Application 2.10.0

Question: Hi all, I’m having trouble publishing forms. I have the Form Entry App and xForms Modules installed and want to create some custom forms… When i go to “Manage Forms” -> Form and tick the “Published” tick box, i find when i go to the main page and select “Form Entry” - > patients record, the published forms don’t get displayed. It worked once but now every time i “Publish” a form it doesn’t display in the list.

UPDATE I found there are a number of default services not running and may be the cause.

The only ones i have listed are “Process HL7 Task” which is running and “Auto Close Visits Task” which is stopped.

Is there a list of Schedulable Classes and how to enable/add them.

If you are using xforms, you will need to first load them in the xforms designer and then save.

Hey Daniel, I’ve tried that and still nothing.

I’ve tried publishing the default forms by ticking the “Published” box and they don’t display either. When i go to the “Form Entry” screen. i.e. Home -> Form Entry -> Select Patient. Under the Forms tab it just says None.

What exactly did you try?

Hi Daniel,

I go to “Manage Forms” and then open one of the default forms. I then go to “Design XForm” and check what it looks like (No changes). Then i save the form and exit the XForm designer. Once i’m back at the “Edit Metadata” page, i then select “Published” and “Save Form”. When i go to a patients record and select “Form Entry” the form doesn’t display.

Which version of the OpenMRS platform and xforms module, are you running?

OpenMRS Version: 2.3.0 Build b3ade0

XForms: 4.3.12

Can you share the server side log via

Hi Daniel,


Ping me when you get some free time and we go through it via

Thanks Daniel, will do.

Hey Daniel,

I have some time today if you are free?