problem in the report application in Bahmni EMR.

I guess this would be the solution for every problem in the Bahmni EMR report application

Hi madanpaudel,

Can you please tell the problem that you are facing in report application ?

1 Like

actually there is no any response when i click on run report button at the report application.I am running bahmni on virtual box with cent os and my host machine is running os x.

1 Like

another point that can be noted is only the chorme is supporting the date/calender format of bahmni on start and end date field of the report application. when i run the application on the firefox the start/end date field seems to be blank with no any feature provided by the application.

Inside vagrant, can you please check 1)Whether you have installed bahmni-reports rpm or not ? you can check that by running the following command: yum list installed | grep bahmni
If it is not installed, please do install it. 2)If it is installed check whether bahmni-reports service is running or not ? You can check that by running the following command: service bahmni-reports status

1 Like

the bahmni-reports service is started and the output of yum list installed | grep bahmni is

bahmni-certs.noarch 1.0-48 @bahmni bahmni-emr.noarch 0.83-289 @bahmni bahmni-erp.noarch 0.83-36 @bahmni bahmni-erp-connect.noarch 0.83-36 @bahmni bahmni-installer.noarch 0.83-142 @bintray–bahmni-rpm bahmni-lab.noarch 0.83-34 @bahmni bahmni-lab-connect.noarch 0.83-289 @bahmni bahmni-openmrs.noarch 0.83-8 @bahmni bahmni-reports.noarch 0.83-31 @bahmni bahmni-web.noarch 0.83-289 @bahmni epel-release.noarch 6-8 @bintray–bahmni-rpm python-gdata.noarch 2.0.11-1.el6 @bahmni

Chrome is the recommended browser.

Can you please provide some info on how you installed bahmni. How did you install bahmni ? Did you install using bahmni command line (bahmni install command) or Did you download the packaged box by cloning bahmni-vagrant(running vagrant up) ?

Is the page blank or shows some error. If it is blank, share the logs at /var/log/bahmni-reports/bahmni-reports.log Else, share a screenshot of the page.

I installed bahmni by downloading the package box and cloning bahmni-vagrant (running vagrant up). which page are you asking about…? when i run the report application on google chrome the problem is that the button Run Report is staying null,without any change.if you are asking about after clicking the run report button then No, i am not redirected to any page not a blank one.

here is the screen shot of the error i got on browser console when i click Run Report button. here is the bahmni-reports.log

okay the problem is lodash.min.cd62e1be.js is available in my vagrant under /opt/bahmni-web/etc/bahmniapps/components/lodash/dist

/script This script declaration is present in /opt/bahmni-web/etc/bahmniapps/reports/index.html file. but in the browser console still same error is present. lodash/dist directory is not under the browser source bahmni/coponents. any help to load the lodash directory would be appreciated..

PROBLOM SOLVED. actually the problem was because of the malware in my browser.It worked without any problem when i scan my system for malware and removed all malware found.

1 Like

I also have aproblem with mine, am using chromium browser and when i try to run any report it shows