Populating Pool of Patient Identifiers

I am trying to replicate the creation of a pool of patient identifiers using our patient identifier type in Bahmni that I previously created in OpenMRS reference app 2.5.

The addition of the new identifier type appears to have been successful but when I declare an identifier source for the new id I get the following error.

The source screen did not request the file containing the identifier pool.

I have just noticed that the openmrs admin screen has 2 links to Manage Patient Identifier Sources The first under Patients and the second under Id Generation. It was the former that failed. I have since tried the latter and curiously it worked fine.

@mafrica, does this mean that this issue is now resolved for you?

(What are the URLs of the two different screens. Just looking at the OpenMRS demo server I do see links in both sections, but they point to exactly the same place.)

For me the issue immediate issue is resolved, but I guess having 2 links where only one seems to function is at bet confusing.