Please help me to get a Bahmni demo installation running!

I am a newbie to Linux and I am a medical practitioner with a MSc in Health Informatics, not a computer engineer :slight_smile:

I successfully managed to install CentOS 6.7 and got familiar with the basic commands in the terminal. Then I followed the steps of installation in the Bahmni wiki https://bahmni.atlassian.net/wiki/display/BAH/Install+Bahmni+on+CentOS

I tried the installation many times on a fresh CentOS install where I came across different problems each time. I made sure that all the necessary services listed in the tutorial was running when I tested.

  1. httpd service was not running, I figured out how to get it running as per instructions in the website
  2. iptables service was blocking the access to the apache server and I figured out how to stop it.
  3. Managed to load the page https:///home. But either the page got stuck with a spinning circle or came up with an error message.
  4. If I try to load other web pages e.g. https:///openmrs, apache server returns an error message saying the service is temporarily unavailable.
  5. I also tried the new rpm install on a fresh CentOS with the command ‘bahmni install’ and realised that way the mysql server and some of the other necessary packages are not installed.

I wonder whether my installs so far haven’t had the apache server properly configured. I also wanted the demo database installed and I do not know if it was downloaded. I can paste the logs here if anybody want to have a look. I hope there will be somebody who can take me through the right steps.

Hello @herath.

Thank you for trying out Bahmni, and being patient with doing all these steps.

Can you please do the following, so that everything is fresh, and its easier to help you:

  1. Setup a fresh CentOS v6.7 server.
  2. Setup Bahmni using the steps mentioned in https://bahmni.atlassian.net/wiki/display/BAH/Install+Bahmni+on+CentOS
  3. Start the various services as mentioned on the above page. If you start openmrs service, please wait for about 5 mins before proceeding with below steps.
  4. Check if http://your-ip/openmrs is running and you can login with superman user
  5. Check if http://your-ip/bahmni is running and you can login with superman user

If openmrs isn’t running, please re-install openmrs using yum remove openmrs yum install openmrs-1.12.0-373

Start openmrs service, and wait for about 5 mins, and then check step 4 and 5 above again.

Please let me know how this goes. Else, paste logs for /var/logs/openmrs/openmrs.log file on pastebin.com and share url here.

Thank you very much for the quick reply @gsluthra. I really appreciate it.

I used the GUI install for CentOS 6.7.

I hope that is the right choice. Should I use ‘yum update’ before installing bahmni?

I will let you know how the rest of the install went.

Basic server is fine. You can try and perform a yum update for installing any mandatory security patches, before installing Bahmni.

Hi @gsluthra,

I followed your instructions but had no luck logging in to Bahmni or openmrs. I reinstalled openmrs and left the machine overnight, still no luck. http://my-ip/bahmni gives this error;

And the pastebin url for the openmrs log is http://pastebin.com/bSKbq8xn

I hope you can help me.

When I try to login http:/my-ip/openmrs I get this;

@gsluthra if you have time to ssh my server I am quite happy as this is a demo machine. Please let me know if you want to do it. Thanks.

I see this in your logs:

java.net.UnknownHostException: centos.home: centos.home: Name or service not known

Can you check if your /etc/hosts file has an entry for your hostname mapped to 127.0.0.1 More details here: http://stackoverflow.com/questions/6484275/java-net-unknownhostexception-invalid-hostname-for-server-local

Basically when you say “ping [hostname]” or “ping 127.0.01”, you should not get any error on your command line.

Yes! @gsluthra, you sorted it out. I successfully registered an imaginary patient and put some medical information.

Now my next task is to do a CentOS install from scratch and try to install Bahmni myself and find out what went wrong. I hope you can tell me what you did to fix my current setup. It is going to be a lot of learning. Tinkering with linux is addictive :slight_smile:

@gsluthra, in the UK we have mature EHR software. I use something called SystemOne in a primary care setting;

But this is not the case where I am originally from-Sri Lanka.

My batch mate in Sri Lanka is a consultant physician. He runs a diabetic clinic in a government hospital (free medical care) and he does this on paper at the moment. I want to install an EHR software for him, and bahmni seems to be the ideal candidate. I am doing this for him as a charity project with recycled hardware. I am also planning to get a Sri Lankan University involved for local research in EHRs in medical practice in Sri Lanka.

@herath: Glad that things are working now for you.

Some things I did on the machine:

Your machine’s hostname was “centos.home”. I ensured one can ping the machine with that hostname, by making an entry in /etc/hosts againt 127.0.0.1 (as per the stack overflow link I pasted earlier).

I realized that for some reason bahmni-emr install didn’t put the OpenMRS modules in /opt/openmrs/modules. The folder was empty. So, I uninstalled bahmni-emr and reinstalled via

“yum remove bahmni-emr” “yum install bahmni-emr-0.80-373”.

You can see the current version of rpm by saying

“yum info bahmni-emr”

I switched off iptables and selinux (for the time being). To switch off selinux, please check this link:

I also reinstalled openmrs, using same command I had mentioned above.

Then restarted openmrs service, and httpd service.

The RAM on your machine is only 3GB. Its less, and hence openmrs can timeout since response can be very slow. Please refer to this document for Bahmni system requirements. I would suggest setting RAM to 8GB if you want to run all services. : https://bahmni.atlassian.net/wiki/display/BAH/System+Requirements

Bahmni has been designed keeping in mind the needs to low resource hospitals and clinics. We want to ensure that Bahmni is free / open source, and hence Bahmni installs on Centos Linux. Also, we realized that every hospital has different needs like different forms, different workflows, etc – and don’t have the resources to pay for programmers to customize EMR. Therefore, Bahmni has been designed to allow its EMR screens to be modified using widgets & controls configurable via JSON files. Also Clinical forms can be created easily via CSV uploads.

One more example is that SMS notification isn’t still in Bahmni, because the places we target, have patients who come to hospitals from very far, are very poor, and many times don’t own a personal mobile phone. Hence, the SMS notification feature was lower in demand than say - Order Sets, Ease of Configuration, Reports, Responsive Design, xRay integration, etc. SMS notification for Health care providers may be higher in priority. Bahmni team prioritizes features keeping in mind the needs of rural / low resource / cost effective areas, and not the super expensive for-profit hospitals. Which is why, you may find differences in the way Bahmni appears with regards to some commercial EMRs.

I hope this helps. We would love to get more feedback from you on how can Bahmni become better! : )

After doing a bit of tinkering, hitting a lot of brick walls and learning a lot of basics of linux (thank you google) I figured out a reliable way of getting Bahmni to install and run.

Step 1 Do a clean install of Centos 6.7. I installed the ‘Desktop’ option as I am a newbie.

Step 2 Open the terminal as root, update the os and create an empty script.

yum update

vi install-bahmni.sh Press i to go into INSERT mode. Copy and paste this reference script on to vi.

press keys esc : w q

Step 3

chmod +x install-bahmni.sh

Step 4-set the variable to the latest version number (0.81 at the moment)

export BAHMNI_VERSION=0.81

Step 4-run the install script

./install-bahmni.sh

Enjoy :smiley:

Yes. These instructions are correct.

Although if you follow the instructions mentioned here: https://bahmni.atlassian.net/wiki/display/BAH/Install+Bahmni+on+CentOS, one can take an easier route to download the install-bahmni.sh script by executing this command:

Download the install script

curl https://raw.githubusercontent.com/Bahmni/bahmni-vagrant/master/packer/scripts/base-v80.sh >> install-bahmni.sh

The above command uses “curl” to download a file from URL, and write it into install-bahmni.sh.

Plus I would have recommended (as per page above), to use V0.80, over V0.81, since the current V0.81 installs a very basic version of OpenERP, that requires you to install additional modules to be useful. But, maybe right now you don’t need OpenERP, in which case V0.81 might be ok for you.

thanks @gsluthra:+1:.