Platform installed and running, but no user interface module installed.

Hey, everyone. I’m trying to get this software set up for a clinic in Haiti and keep getting this response. Any insight? I have the error logs but can’t upload on here since I am a new user.


It seems you have dowloaded and deployed the platform version of the OpenMRS instance. If you want to test the system you can download the reference application standalone version. If you want to deploy on server like tomcat, you need to download the platform war file and the reference application module from here. Since you seem to already have the platform deployed you only need to download the modules, unzip the folder and copy its content to OpenMRS module directory. The OpenMRS data directory location depends on the OS you are on, give the details of your OS and we will help you figure it out (I tried locating the page describing this on OpenMRS wiki, unfortunately for some reason wiki won’t log me in).

1 Like

Hi Wiila ,

Thank you for replying. I Installed the Standalone Reference Application 2.6.1 which has tomcat and MySQL packaged. This installs and opens up the app on my mac book fine. But the same one while installing on Linux Ubuntu throws lots errors about missing modules and ultimately show the page in the screenshot.Strangely, it shows the version installed as but what I installed is 2.6.1 Ref app.

One of the errors I’m seeing is this one.

Expanding: appdata\owa/conceptdictionary.owa into appdata\owa/conceptdictionary ERROR - OwaActivator.contextRefreshed(111) |2017-11-23 22:42:06,295| Failed to deploy OWA from zip file: conceptdictionary.owa appdata\owa/conceptdictionary/manifest.webapp (No such file or directory) at Method) at at at org.codehaus.jackson.JsonFactory.createJsonParser( at at org.openmrs.module.owa.impl.DefaultAppManager.installApp( at org.openmrs.module.owa.activator.OwaActivator.contextRefreshed( at org.openmrs.module.ModuleUtil.refreshApplicationContext( at org.openmrs.module.web.WebModuleUtil.refreshWAC( at org.openmrs.web.Listener.performWebStartOfModules( at org.openmrs.web.Listener.performWebStartOfModules( at org.openmrs.web.Listener.startOpenmrs( at org.openmrs.web.WebDaemon$

@dricupero for the server that is running the first screen that you posted, can you paste the log file contents at

thanks for responding. sorry for the delay om my response, I kept getting an error every time I tried to post.

here is my pastern url >

I am using ubuntu 16

any luck with the pastebin URL @dkayiwa?

Are you able to instead just download and run the latest standalone release of the reference application?