OpenMRS startup error

I am attempting to do the initial setup of OpenMRS, but it seems that I have run into some error that has to do with the database. I have a fresh database waiting on my local instance, password and everything line up as far as I am aware, but I get an error saying OpenMRS is not able to start.

I am using MySQL version 8.0.

Here is the pastebin:

I also have the entire cmd log if you need that (everything after mvn jetty:run).

Any help would be greatly appreciated.

@minutesperbeat do you have a file in your working folder?if yes what are the log in credentials ?

I left out the password as I don’t think its necessary to include that. The reason its using root user is because I was having an issue with using MySQL 8.0 where the authentication method being used by the auto-generated account (when doing the Database setup) was out of date.

Essentially the setup for the database would create a user that used the authentication method that 8.0 didn’t seem to recognize. Whenever I tried to manually change the user that it was generating to use a different authentication method it would think the user didn’t exist anymore and just remake it.

Does this mean that you are now good?

Sadly no.

I have version 2.1 checked out and it builds just fine now, but when i do mvn jetty:run from the webapp folder it brings me to the initial setup. I go through the simple installation, give it my password for the root user, and when I get to the part with the loading bars it fails:

Since it’s initial setup I would assume its going to make the file durring the setup process. But it can’t since for some reason it can’t connect to the database. The windows service is running and workbench says its running as well.

Can you try MySQL version 5.7?

That worked very well, may I ask why 5.7 isn’t the recommended version when going through these ?

I remember reading somewhere that 8.0 was okay to use, if I can find where that was should it be altered to state that its recommended to stick with 5.6 or 5.7?

So it seems to be running now, but after getting the REST module and running mvn clean install on it the server wont pick up the module and still has the default " If you are seeing this page, it means that the OpenMRS Platform is running successfully, but no user interface module is installed. Learn about the available User Interface Modules"

Everything appeared to work properly when I ran it, so my question is where/how am I supposed to put the files from github for the modules in order for mvn clean install to build it properly so it will be picked up when running mvn jetty:run from the webapp folder?

Can you share the server log?

Hopefully this is what you were looking for.

Put the modules in this folder and restart openmrs: C:\Users\nmmcc\Application Data\OpenMRS\modules

Still having issues where it shows that end of setup screen.

Your modules should have a .omod file extension.

They have omod folders. I don’t know where the .omod file is that is meant to act as the whole module. I am probably missing something really obvious.

They should not be folders. They should be files with a .omod extension. For instance: legacyui-1.5.0-SNAPSHOT.omod

Where am I supposed to get that? I am meaning to work on the RESTWS module, so I thought forking the git for it and making the branch with the issue id was what I was supposed to do to get the modules. then run mvn clean install within the newly cloned folder.

Can you go through this?

Sure thing, I tried already but it didn’t seem to result in anything as no folders were being generated. I assumed it was because I wasn’t working within the correct location when going through those instructions. Is there anywhere in particular I should be running that SDK setup? like in the cloned files i have for the core? Or does it not matter?

Can you run the sdk setup again and choose a reference application distribution?

I am going through the process again and when i typed mvn openmrs-sdk:help it produced this:

This doesn’t seem to match what I was meant to get, can you confirm or let me know its alright?