openmrs sdk distribution options

i am installing openmrs sdk instance with the guide of this manual OpenMRS SDK - Documentation - OpenMRS Wiki when i run mvn openmrs-sdk:run i get these options

`You can setup the following servers:

  1. Distribution
  2. Platform

Which one do you choose? [1/2]: when i choose 1 which is distribution i end up with these options

You can deploy the following versions of distribution:

  1. Reference Application 2.3.1
  2. Reference Application 2.2
  3. Reference Application 2.1
  4. Other…

Which one do you choose? [1/2/3/4]: 1` of which i think the version presented is for platform. Besides that when i select 1 i end up with this error can someone help me with the way forward?

@kimote Kindly the error you are getting could be because of the mysql version you are using. Kindly ensure you are running mysql 5.6. which supports the the listed openmrs versions.

1 Like

ooh i have realized i was running mysql version 8 but thank you

You can use MySQL 8 if you choose 4. Other and then specify version 2.12.0-SNAPSHOT

@kimote and this is because version `2.12.0-SNAPSHOT comes with openmrs core 2.4 which is compatible with mysql 8

Kindly sorry for a bother. Basing on @kimote’s question does it mean there will be no more listing of the Reference Application version?

thank you let me try that

1 Like

@jwnasambu I don’t have an explicit answer for you. However, I was getting the same error as @kimote when trying to list Reference Application which was not the case before on my old pc. And also installing mysql 5.6 on my new pc seems to be a tag of war. I tried to install mysql 5.7, but it has not yet worked fine, probably due to configurations. I am gonna try as @dkayiwa with mysql 8 and see.

@settix I find it confusing when the platform versions are the ones listed in place of the reference application. Am creating a server for testing purposes and the issue seems to have been sorted out. You can try it out again.

@settix just be careful with the RefApp version you are running not all versions support mysql 8.

@jwnasambu Noted please. I am gonna give it a trial again.