OpenMRS Reference Application 2.10.0 error when installing

I downloaded the OpenMRS Reference Application 2.10.0, tried to install it, and received this error Caused by: org.springframework.beans.factory.NoSuchBeanDefinitionException: No qualifying bean of type [org.openmrs.module.appframework.service.AppFrameworkService] found for dependency: expected at least 1 bean which qualifies as autowire candidate for this dependency. Dependency annotations: {@org.springframework.beans.factory.annotation.Autowired(required=true)} at at at at org.springframework.beans.factory.annotation.AutowiredAnnotationBeanPostProcessor$AutowiredFieldElement.inject( … 30 more

I downloaded JDK 14 prior to launching the installation of OpenMRS.

How can I resolve the error? Thanks for any help you can provide, dear Community!

@tbernier can you share the full error logs using

Secondly which java version are you using ?

As @gcliff has asked…it is noteworthy from this talk post that you need Java 8 for reference App 2.10 to run smoothly…

And aaar @tbernier don’t edit your post when answering a question coz then a notification is not send to the responders…just continue with replying

@tbernier for the JDK 14 that you installed, you need to use the referenceapplication-standalone-snapshot from here:

1 Like

Hello Everyone,

Thanks so much for helping me out.

For Java, I downloaded and installed jre-8u251-macosx-x64.dmg. I forgot to mention this earlier: I am using a Mac laptop, OS High Sierra v10.13.6.

I tried installing again and continue to receive the same error. It’s my first time using pastebin, so let me know if you can access this

I was trying to install the demo version, by that I mean the first option when the “Configure your OpenMRS Installation window” appears after I click on openmrs-standalone.jar. If I can’t install at all I can always use the OpenMRS Demo version available on the website.

Have a great day! Therese (I’d put in my accents but not sure if it would garble the text.)

The application is still using the other version of Java. Would it be easier to just download the one i gave above?

It might but I’m not sure what I should do with all of the links on the page? Should I click on all of them and download what is there?

It worked! Although this error occurred

Can I create a login for the demo install or do I have to keep using admin Admin123 as credentials?

I should add what I posted in pastebin I received when I clicked on “Configure Atlas.”

You can ignore the Atlas setup.

I have fixed the Atlas problem at: