build failure.


I am working on completing part of the work i started ie adding passwordreset via email end points to the rest webservice. I have been getting some failures and tried figuring out what is wrong and couldn’t get it until i moved back to master then i got the same build failure. Below is the exact message i get after i rebase with upstream master. i remember i had it working on the branch i was working on until recently when i rebase. Even on a master branch which doesnot have my work i still get the same failure. I will appreciate some assistance in figuring out what is wrong.

and Here # Created at 2018-12-17T07:28:38.402java.lang.NoClassDefFoundError: org/openmr - is found the result of the / file

Does a fresh clone of this module compile successfully?

Let me do it

@dkayiwa I just finished compiling a fresh clone and get the exact same error above

Can you share a pastebin error log for the fresh clone?

Here is the log

Can you also pastebin the contents of the pom.xml file for your local omod-2.2 folder?

Here it is

What does this command return? mvn -v

Apache Maven 3.3.9 (bb52d8502b132ec0a5a3f4c09453c07478323dc5; 2015-11-10T17:41:47+01:00)

Maven home: /usr/local/apache-maven-3.3.9

Are you sure that is all?

Apache Maven 3.3.9 (bb52d8502b132ec0a5a3f4c09453c07478323dc5; 2015-11-10T17:41:47+01:00)

Maven home: /usr/local/apache-maven-3.3.9

Java version: 1.8.0_181, vendor: Oracle Corporation

Java home: /Library/Java/JavaVirtualMachines/jdk1.8.0_181.jdk/Contents/Home/jre

Default locale: en_CM, platform encoding: UTF-8

OS name: “mac os x”, version: “10.13.6”, arch: “x86_64”, family: “mac” harisu$

Do you think you can wipe out your .m2 folder and compile again?

Ok, So I shouldn’t compile core this time around?. because last i cleared .m2 I compiled core then followed by restwebservice.

You do not have to.

Thanks clearing the .m2 folder did resolve the issue.