Openmrs is not opening after cloning openmrs-module-bahmniapps

Openmrs is nont opening after cloning openmrs-module-bahmniapps

I have tried to floow all instructions on Bahmni-Web Configurations (docker).

I. croned openmrs-module-bahmniapps

  1. For required tools and dependencies, i managed to install Yarn (npm install -g yarn), Grunt (npm install -g grunt-cli), yarn install and yarn ci (will internally trigger grunt).

  2. I did’t install Compass (Compass compiles SASS/SCSS into CSS)

  3. I Copied the path of openmrs-module-bahmniapps directory and set it to BAHMNI_APPS_PATH environment variable in the .env ( BAHMNI_APPS_PATH=C:\Users\Administrator\Documents\bahmrs\bahmni-docker\bahmni-standard\openmrs-module-bahmniapps)

  4. In the docker-compose.yml file on bahmni-web service I uncommented the volumes section with the volumes starting with BAHMNI_APPS_PATH in

bahmni-web: image: bahmni/bahmni-web:${BAHMNI_WEB_IMAGE_TAG:?} profiles: [“emr”,“bahmni-standard”,“bahmni-mart”] volumes: - “${CONFIG_VOLUME:?}:/usr/local/apache2/htdocs/bahmni_config/:ro” - “${BAHMNI_APPS_PATH:?}/ui/app/:/usr/local/apache2/htdocs/bahmni” - “${BAHMNI_APPS_PATH:?}/ui/node_modules/@bower_components/:/usr/local/apache2/htdocs/bahmni/components” logging: *log-config restart: ${RESTART_POLICY}

  1. Lastly i typed docker-compose up -d bahmni-web

The problem is openmrs is not opening but odoo and lab are opening and i can login.

Please can someone help me. Thanks.

what does the log say?

@rahu1ramesh @mohant

Without the logs, it’s challenging to pinpoint the exact issue. However, I can suggest a couple of troubleshooting steps to narrow down the problem:

  1. First, try accessing the OpenMRS instance directly by hitting the URL https://localhost/openmrs/ (or append /openmrs/ to your base URL if you’re using a different setup). This will help verify if OpenMRS is up and running.

  2. If the URL works fine and OpenMRS seems to be running correctly, then the issue might be related to the volume-mounted codebase. In that case, try removing the volume-mounted openmrs-module-bahmniapps and bring the container up from the published image.

    Here are the steps you can follow:

    • Remove the volume mount for openmrs-module-bahmniapps from the docker-compose.yml file.
    • Bring the container up using the image published without the volume-mounted codebase.

If OpenMRS works fine after using the image without the volume-mounted codebase, it confirms that the issue is indeed related to the volume-mounted codebase.