OpenMRS failes to load after installing Sync1.30.omod

Hello all!

I tried to add the sync module to OpenMRS 2.6 stand alone and now get the message:

org.openmrs.module.MandatoryModuleException: The following modules are marked as ‘mandatory’ but were unable to start: sync why trying to load OpenMRS.

Thought it would work since it’s in the repo but that was not the case. Any insight on how to remove the mandatory option for this module from the config would be greatly appreciated. Thanks for the help and sorry for the ignorance but I’m a bit of a noob!


Can you share the tomcat log using You will find this in your standalone’s root folder under tomcat/logs

Good evening Daniel, and thank you for the reply! is the log I generated today. I am working on this for an organization called Hands On Global, who are working in Zanskar, India setting up a hospital for the Tibetan people living there. I was trying to send a server there and keep one here as their satellite internet is spotty and thought the Sync module would be a great way to mirror for redundancy… woops! I appreciate any help you can provide!


We are running away from that old sync module to a new one because of the problems we have experienced with it.

Do you think you can test out sync2 and give us feedback on how to improve it for your setting?

I’d love to, but first things first, I have to be able to run it! LOL I’ve got pretty decent knowledge of remote access and networking and would be glad to setup a remote mirroring and send you back whatever logs and info you’d like. Once up and running I’ll read through the Sync2 pages and get familiar with it. Sorry for the tardy response, I’ve been busier than normal at work. Once again, thank you for the assistance!


In other words, are you still interested in running the one we do not recommend and hence moving away from? :slight_smile:

No, I’m not attached to Sync1.3, but I have data in this database and need OpenMRS working. When it is working I’ll gladly install Sync2, but I can’t do anything until I’m able to access OpenMRS.

OK. In that case, just go to the modules folder and delete the sync omod file. After which you will go to your global_property table and delete all settings whose names start with “sync.”

Pardon the ignorance, told you I was a noob at this, but I’m having trouble locating the global properties table. I had already deleted the omod file but researching the global_properties on the website the info is just blank; Mostly it references version 1.x, I’m using 2.6 if that makes a difference. Thanks again bud!


Are you first of all able to connect to your database?

Yes sir! SQL is up, ran mysql -u openmrs -p --port=3316 --host= and used the PW in my properties files. SQL came back;

Welcome to the MySQL monitor. Commands end with ; or \g. Your MySQL connection id is 53 Server version: 5.5.9 MySQL Community Server (GPL)

Copyright © 2000, 2010, Oracle and/or its affiliates. All rights reserved.

Oracle is a registered trademark of Oracle Corporation and/or its affiliates. Other names may be trademarks of their respective owners.

Type ‘help;’ or ‘\h’ for help. Type ‘\c’ to clear the current input statement.

Next, are you able to see data in your global_property table?

What’s the syntax? I’ve been reading the MYSQL manual but am running in circles… When trying to run show tables; I get no database selected, I use the the show databases; and see the openmrs database but not sure the syntax on selecting the database. Or am I incorrect entirely? LOL thanks again bud!


use openmrs;

SELECT * FROM global_property;

That worked! I have 328 rows in set. Thanks JM!

Now do: SELECT * FROM global_property where property like “sync.%”

Can you use a tool like pastebin for such long text? Then you only include a paste url here.

Gotcha, sorry about the poor etiquette! I was on a call earlier and seen the message come in and was eager to get back with y’all!


Now edit your previous post by removing what is in the pastebin link. :slight_smile:

LOL, sorry DK!