# OpenMRS Core 2.5.0 Installation Java Error

**URL:** <https://talk.openmrs.org/t/openmrs-core-2-5-0-installation-java-error/35896>\
**Category:** Uncategorized\
**Created:** [February 16, 2022, 2:22pm UTC](https://talk.openmrs.org/t/openmrs-core-2-5-0-installation-java-error/35896 "2022-02-16T14:22:03Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![mzeeocen](https://talk.openmrs.org/letter_avatar/mzeeocen/32/5_5575768a8748004e209b776fc1b2916d.png) [@mzeeocen](https://talk.openmrs.org/u/mzeeocen)\
**Post date:** [February 16, 2022, 2:22pm UTC](https://talk.openmrs.org/t/openmrs-core-2-5-0-installation-java-error/35896/1 "2022-02-16T14:22:03Z")

</div>

Installation error on ubuntu 20 server x64, tomcat8, openJDK11, mysql8 failing with multiple “Error creating bean with name” at the very last step of updating database. Do assist please with more pointers.

---

<div class="post-metadata">

**Author:** ![kdaud](https://talk.openmrs.org/user_avatar/talk.openmrs.org/kdaud/32/13346_2.png) [@kdaud](https://talk.openmrs.org/u/kdaud)\
**Post date:** [February 16, 2022, 2:28pm UTC](https://talk.openmrs.org/t/openmrs-core-2-5-0-installation-java-error/35896/2 "2022-02-16T14:28:18Z")

</div>

What happens when you downgrade JDK to 1. 8 and re-do the process?

---

<div class="post-metadata">

**Author:** ![tendomart](https://talk.openmrs.org/user_avatar/talk.openmrs.org/tendomart/32/6753_2.png) [@tendomart](https://talk.openmrs.org/u/tendomart)\
**Post date:** [February 16, 2022, 2:32pm UTC](https://talk.openmrs.org/t/openmrs-core-2-5-0-installation-java-error/35896/3 "2022-02-16T14:32:43Z")

</div>

@mzeeocen We currently support **Tomcat 8.5+ and 9** for **Platform 2.5.0** check [OpenMRS Platform 2.5.0 Released – OpenMRS.org](https://openmrs.org/2021/12/24/openmrs-platform-2-5-0-released/) and [Tomcat Version with deprecation of Tomcat7](https://talk.openmrs.org/t/tomcat-version-with-deprecation-of-tomcat7/34043)

Are you running running on **Tomcat 8.5+**?

Can you also provide your error log at [pastebin.com](http://pastebin.com) ?

---

<div class="post-metadata">

**Author:** ![mzeeocen](https://talk.openmrs.org/letter_avatar/mzeeocen/32/5_5575768a8748004e209b776fc1b2916d.png) [@mzeeocen](https://talk.openmrs.org/u/mzeeocen)\
**Post date:** [February 16, 2022, 2:54pm UTC](https://talk.openmrs.org/t/openmrs-core-2-5-0-installation-java-error/35896/4 "2022-02-16T14:54:13Z")

</div>

same error still persists, here is java version

# java -version

openjdk version “1.8.0\_312” OpenJDK Runtime Environment (build 1.8.0\_312-8u312-b07-0ubuntu1~20.04-b07) OpenJDK 64-Bit Server VM (build 25.312-b07, mixed mode)

---

<div class="post-metadata">

**Author:** ![mzeeocen](https://talk.openmrs.org/letter_avatar/mzeeocen/32/5_5575768a8748004e209b776fc1b2916d.png) [@mzeeocen](https://talk.openmrs.org/u/mzeeocen)\
**Post date:** [February 16, 2022, 3:11pm UTC](https://talk.openmrs.org/t/openmrs-core-2-5-0-installation-java-error/35896/5 "2022-02-16T15:11:30Z")

</div>

Tomcat version: # Apache Tomcat/8.5.75

Below link to error in pastebin

> **[OpenMRSInstall Java Errors - Pastebin.com](https://pastebin.com/0egVuTff)**
>
> Pastebin.com is the number one paste tool since 2002. Pastebin is a website where you can store text online for a set period of time.

---

<div class="post-metadata">

**Author:** ![tendomart](https://talk.openmrs.org/user_avatar/talk.openmrs.org/tendomart/32/6753_2.png) [@tendomart](https://talk.openmrs.org/u/tendomart)\
**Post date:** [February 16, 2022, 3:25pm UTC](https://talk.openmrs.org/t/openmrs-core-2-5-0-installation-java-error/35896/6 "2022-02-16T15:25:48Z")

</div>

Can you delete the whole installation and try again and we see what happens.

---

<div class="post-metadata">

**Author:** ![mzeeocen](https://talk.openmrs.org/letter_avatar/mzeeocen/32/5_5575768a8748004e209b776fc1b2916d.png) [@mzeeocen](https://talk.openmrs.org/u/mzeeocen)\
**Post date:** [February 16, 2022, 3:49pm UTC](https://talk.openmrs.org/t/openmrs-core-2-5-0-installation-java-error/35896/7 "2022-02-16T15:49:48Z")

</div>

done that, deleted openmrs from webapps & re extracted new one, same failure at 99%.

---

<div class="post-metadata">

**Author:** ![tendomart](https://talk.openmrs.org/user_avatar/talk.openmrs.org/tendomart/32/6753_2.png) [@tendomart](https://talk.openmrs.org/u/tendomart)\
**Post date:** [February 16, 2022, 5:17pm UTC](https://talk.openmrs.org/t/openmrs-core-2-5-0-installation-java-error/35896/8 "2022-02-16T17:17:30Z")

</div>

Let me Analyse this to see the real cause

`Invocation of init method failed; nested exception is org.hibernate.search.exception.SearchException: HSEARCH000103: Unable to initialize IndexManager named 'org.openmrs.ConceptComplex'`

---

<div class="post-metadata">

**Author:** ![tendomart](https://talk.openmrs.org/user_avatar/talk.openmrs.org/tendomart/32/6753_2.png) [@tendomart](https://talk.openmrs.org/u/tendomart)\
**Post date:** [February 16, 2022, 5:24pm UTC](https://talk.openmrs.org/t/openmrs-core-2-5-0-installation-java-error/35896/9 "2022-02-16T17:24:11Z")

</div>

@mzeeocen try to cd into your openmrs installation directory and check the read / write permissions with l **s -la** and let’s see the results .

---

<div class="post-metadata">

**Author:** ![mzeeocen](https://talk.openmrs.org/letter_avatar/mzeeocen/32/5_5575768a8748004e209b776fc1b2916d.png) [@mzeeocen](https://talk.openmrs.org/u/mzeeocen)\
**Post date:** [February 16, 2022, 7:48pm UTC](https://talk.openmrs.org/t/openmrs-core-2-5-0-installation-java-error/35896/10 "2022-02-16T19:48:44Z")

</div>

RW permissions to tomcat

/var/lib/tomcat8/webapps/openmrs# ls -la total 28

drwxr-xr-x 5 tomcat tomcat 4096 Feb 16 15:34 . drwxr-x— 8 tomcat tomcat 4096 Feb 16 15:34 … drwxrwxr-x 2 tomcat tomcat 4096 Dec 22 13:37 images -rw-rw-r-- 1 tomcat tomcat 1869 Dec 22 13:37 index.htm -rw-rw-r-- 1 tomcat tomcat 853 Dec 22 13:24 initialsetup drwxr-xr-x 3 tomcat tomcat 4096 Feb 16 15:34 META-INF drwxr-xr-x 7 tomcat tomcat 4096 Feb 16 15:36 WEB-INF

---

<div class="post-metadata">

**Author:** ![dkayiwa](https://talk.openmrs.org/user_avatar/talk.openmrs.org/dkayiwa/32/179_2.png) [@dkayiwa](https://talk.openmrs.org/u/dkayiwa)\
**Post date:** [February 16, 2022, 8:25pm UTC](https://talk.openmrs.org/t/openmrs-core-2-5-0-installation-java-error/35896/11 "2022-02-16T20:25:51Z")

</div>

Delete the folder named `lucene` in your application data folder and then restart tomcat.

---

<div class="post-metadata">

**Author:** ![mzeeocen](https://talk.openmrs.org/letter_avatar/mzeeocen/32/5_5575768a8748004e209b776fc1b2916d.png) [@mzeeocen](https://talk.openmrs.org/u/mzeeocen)\
**Post date:** [February 17, 2022, 1:00am UTC](https://talk.openmrs.org/t/openmrs-core-2-5-0-installation-java-error/35896/13 "2022-02-17T01:00:48Z")

</div>

Hello all, i seem to have got it working now. The problem was RW rights to /var/lib/OpenMRS, tomcat could not write to this dir & installation could not proceed. Thanks all.

---

<div class="post-metadata">

**Author:** ![injiri](https://talk.openmrs.org/user_avatar/talk.openmrs.org/injiri/32/11452_2.png) [@injiri](https://talk.openmrs.org/u/injiri)\
**Post date:** [April 6, 2022, 7:26am UTC](https://talk.openmrs.org/t/openmrs-core-2-5-0-installation-java-error/35896/14 "2022-04-06T07:26:52Z")

</div>

@here Am getting same error [https://pastebin.com/y8HNhkjm](https://pastebin.com/y8HNhkjm). I have all the drwxr-xr-x privileges in place

---

<div class="post-metadata">

**Author:** ![injiri](https://talk.openmrs.org/user_avatar/talk.openmrs.org/injiri/32/11452_2.png) [@injiri](https://talk.openmrs.org/u/injiri)\
**Post date:** [April 6, 2022, 7:29am UTC](https://talk.openmrs.org/t/openmrs-core-2-5-0-installation-java-error/35896/15 "2022-04-06T07:29:05Z")

</div>

```auto
mysql> select version();
+---------------+
| version() |
+---------------+
| 5.6.16-1~exp1 |
+---------------+
1 row in set (0.00 sec)

```

openmrs 2.3.3

@aojwang @dkayiwa @mzeeocen

---

<div class="post-metadata">

**Author:** ![tendomart](https://talk.openmrs.org/user_avatar/talk.openmrs.org/tendomart/32/6753_2.png) [@tendomart](https://talk.openmrs.org/u/tendomart)\
**Post date:** [April 6, 2022, 8:10am UTC](https://talk.openmrs.org/t/openmrs-core-2-5-0-installation-java-error/35896/16 "2022-04-06T08:10:33Z")

</div>

@injiri What are you doing ?

---

<div class="post-metadata">

**Author:** ![dkayiwa](https://talk.openmrs.org/user_avatar/talk.openmrs.org/dkayiwa/32/179_2.png) [@dkayiwa](https://talk.openmrs.org/u/dkayiwa)\
**Post date:** [April 6, 2022, 8:28am UTC](https://talk.openmrs.org/t/openmrs-core-2-5-0-installation-java-error/35896/17 "2022-04-06T08:28:57Z")

</div>

@injiri delete the `lucene` folder in your application data directory and restart OpenMRS.

---

<div class="post-metadata">

**Author:** ![injiri](https://talk.openmrs.org/user_avatar/talk.openmrs.org/injiri/32/11452_2.png) [@injiri](https://talk.openmrs.org/u/injiri)\
**Post date:** [April 6, 2022, 4:34pm UTC](https://talk.openmrs.org/t/openmrs-core-2-5-0-installation-java-error/35896/18 "2022-04-06T16:34:13Z")

</div>

@tendomart this occurred unexpectedly when redeploying modules on the server. Deleting the lucern folder in the OpenMRS directory did not work.

---

<div class="post-metadata">

**Author:** ![aojwang](https://talk.openmrs.org/letter_avatar/aojwang/32/5_5575768a8748004e209b776fc1b2916d.png) [@aojwang](https://talk.openmrs.org/u/aojwang)\
**Post date:** [April 6, 2022, 7:59pm UTC](https://talk.openmrs.org/t/openmrs-core-2-5-0-installation-java-error/35896/19 "2022-04-06T19:59:47Z")

</div>

Hi @injiri most of our sites experienced the error early this week and we resolved it by making some changes to the tomcat service file. We made the following changes:

```auto
[Service]
ReadWritePaths=/var/lib/OpenMRS/

# Logging
#SyslogIdentifier=tomcat9
StandardOutput=append:/var/log/tomcat9/catalina.out
StandardError=append:/var/log/tomcat9/catalina.out

```

You can adapt the changes as appropriate. You can also refer to the attached file [tomcat9.service.txt](https://talk.openmrs.org/uploads/short-url/az4uLLyzGgn4GFcplOWzGKrkoAD.txt) (1.1 KB)

---

<div class="post-metadata">

**Author:** ![injiri](https://talk.openmrs.org/user_avatar/talk.openmrs.org/injiri/32/11452_2.png) [@injiri](https://talk.openmrs.org/u/injiri)\
**Post date:** [April 7, 2022, 5:52am UTC](https://talk.openmrs.org/t/openmrs-core-2-5-0-installation-java-error/35896/20 "2022-04-07T05:52:51Z")

</div>

Hi @aojwang  
That resolved my issue. Looks like ubuntu auto-updated the tomcat9 instance doing away with the customization we had earlier done on the tomcat9.service file.

---

<div class="post-metadata">

**Author:** ![aojwang](https://talk.openmrs.org/letter_avatar/aojwang/32/5_5575768a8748004e209b776fc1b2916d.png) [@aojwang](https://talk.openmrs.org/u/aojwang)\
**Post date:** [April 7, 2022, 2:14pm UTC](https://talk.openmrs.org/t/openmrs-core-2-5-0-installation-java-error/35896/21 "2022-04-07T14:14:47Z")

</div>

Great to hear. Thanks
