OpenMRS 1.9.7 Upgrade

OpenMRS 1.9.7 Upgrade

We are upgrading openmrs from version 1.9.7 to the newer version but we have this error, please help. Unable to complete the startup. See the server error log for the complete stacktrace. Unable to start OpenMRS. Error thrown was: org.springframework.beans.factory.BeanCreationException: Error creating bean with name ‘serviceContext$child#3’ defined in URL [jar:file:/tmp/tomcat6-tomcat6-tmp/1487595856172.openmrs-lib-cache/simplelabentry/simplelabentry.jar!/moduleApplicationContext.xml]: Cannot create inner bean ‘org.springframework.transaction.interceptor.TransactionProxyFactoryBean#37d1050d’ of type [org.springframework.transaction.interceptor.TransactionProxyFactoryBean] while setting bean property ‘moduleService’ with key [1]; nested exception is org.springframework.beans.factory.BeanCreationException: Error creating bean with name ‘org.springframework.transaction.interceptor.TransactionProxyFactoryBean#37d1050d’ defined in URL [jar:file:/tmp/tomcat6-tomcat6-tmp/1487595856172.openmrs-lib-cache/simplelabentry/simplelabentry.jar!/moduleApplicationContext.xml]: Initialization of bean failed; nested exception is java.lang.NoClassDefFoundError: org/openmrs/api/OrderService$ORDER_STATUS

I supposed you are upgrading to platform 2.x. Correct? If yes, remove the simplelabentry module and try again.

We are upgrading to 1.11.6 not 2.0 In that case the simplelabentry module is not present.

1 Like

Still go ahead to remove it from your modules folder and try again.

1 Like

thanks…its successfull

Thanks, best solution.