Not all components are installed

Hi team, I tried many times to install version 0.85, and every time only the followings are installed: Bahmni-certs Bahmni-emr Bahmni-installer Bahmni-openmrs Bahmni-web

When I use yum command to install OpenERP, it says that postgres9.2 is required.

Is there any wrong that I’m doing? Regards,

Hi Abdul, What is the wiki page you have followed to install Bahmni. And also share the content of setup.yml.

I’m following the Steps for Installing Bahmni v0.85 – using bahmni-installer (Recommended):

I don’t know how to get the content of setup.yml.

You can run the below command to check the contents of setup.yml cat /etc/bahmni-installer/setup.yml Can you please run the below command again to install Bahmni and let us know if you get any errors. bahmni -i local install

when I run cat /etc/bahmni-installer/setup.yml I got this:

To see the list of valid variables in Bahmni please refer to:

Timezone: Asia/Kolkata implementation_name: default selinux_state: disabled

I tried to re-install bahmni again and I got same issue.

Again, if I try to install lab using “yum instal -y bahmni-lab bahmni-lab-connect” it is giving: error: Package: Bahmni-lab-0.85-20.noarch (bahmni) requires postgresql92


You dont need to manually install everything. Please run bahmni -i local install Please let us know if this command ran successfully.

@sravanthi17 That’s what I did (bahmni -i local install) but didn’t install openERP nor OpenELIS. So, I tried manually to install lab but I believe the issue is because of postgresql package.


Can you share screenshot of error message ?

It is not an error other than incomplete process.

Share the screenshot after the running bahmni -i local install

This command will take care of installing the required dependencies for bahmni-lab (like postgres)