Not able to login to OpenMRS-core since liquibase update

Hi everyone. Since a major recent update of liquibase, I am not able to login to OpenMRS-core with the credentials set up in the initializing phase. I fetched the changes and tried it with PostgreSQL ( I had been working recently to make openmrs support postgresql ) and it failed which earlier I was able to do. Then I tried with MySQL and still not able to login. Then I cloned the repo separately and tried and again login failed.

These are steps I followed :

  1. Cloned the openmrs-core repo from https://github.com/openmrs/openmrs-core.

2.ran mvn clean install and build is successful.

  1. Ran mvn jetty:run in webapp directory and set up openmrs on MySQL with login credentials for openmrs as default username - admin and password - Aman@1998

  2. All changesets ran successfully.

  3. Added openmrs legacyui-1.7.0-SNAPSHOT.omod in the modules directory and then restart with mvn jetty:run.

  4. Gave the credentials and login failed.

Link to logs - https://pastebin.com/PvAf99fB

Is anybody else facing the issue or can anyone confirm it or am I missing something?

UPDATE: Irrespective of whatever password you set during initializing phase, login password is always set to Admin123 .

Thanks for reporting the bug, @aman.

I could reproduce it and implemented a fix, details are available under https://issues.openmrs.org/browse/TRUNK-4830.

@aman the pull request from @wolf has been merged. Can you pull and test again?

1 Like

I checked and now everything is working fine. Thanks @wolf.

1 Like