New release 0.90 issues with concepts

Tags: #<Tag:0x00007ff4bf350190>

Hi fellow Bahmni Users, I am new to the forum so hello everybody - up till now I was just a reading user but unfortunately I need your help now guys…

I want to install the new release on CentOS 6.8 because of the new cool appointments feature. I was able to finish the installer ok(PLAY RECAP ********************************************************************* localhost : ok=305 changed=196 unreachable=0 failed=0
) - but then found out that there a few things that are not working as expected. There is no demo data available all thought I didn’t change the system.yml file during installation and furthermore there are no no concepts found within emr.

This is the error message when trying to access clinical dashboard after registration: TypeError: Cannot read property ‘setMembers’ of undefined

consultation/oberservations and order brings up the same error…again

I was trying to find concepts on openmrs administration side when I discovered that there are no concepts available at first, but if I try to search with the concept id (eg ‘33’ Radiology Orders) I am able to find concepts…

Any help is highly appreciated.

Many thanks and regards, Gernot

1 Like

Rebuilding search index did solve the problem.

Go to openmrs -> Administration -> serach index -> rebuild search Index.

Many thanks to @shruthipitta and her post Missing all concepts in Bahmni V 0.90

2 Likes

Hello all,

I have exactly the same issue with the bahmni vagrant box but rebuilding the search index didn’t solve the problem.

Any idea that could help me?

Thanks

Alexis

@alexis.duque can you check /opt/openmrs/log/openmrs.log for any possible error details.

Thanks for your answer :slight_smile:

I have seen in the log that some concept where not found (but they should :thinking: !)

I updated the search index once again, restarted openmrs and it works now.

So, strange behavior

Hi,

I know that this post is very old but Im new to Bahmni and have installed v 0.92 on my centos 7. I have ran into same issue with different error message so I want to share it so that anyone can try it out. error message was showing when open employee dashboard. it states “typeerror: cannot read property ‘setmembers’ undefined”. I rebuild the search index and everything is working fine.

1 Like