Negative One Qty in OpenERP

Hello, can someone please advise where we can update the qty values in OpenERP? Currently, all of our Lab Orders and Procedures come through as -1 and thus the Order Quotation is off. I have checked but can seem to find the actual qty value.

Please advise asap as we are trying to implement.

Thank you!

Hi Denise,

There are two ways of doing what you want

  1. Add “Unit(s)” to the list of “Units to be synced” (I am assuming the unit that you are seeing against your Lab Orders and Procedures is “Unit(s)”) Sales -> Configuration -> Units to be Synced.
  2. Uncheck “Allow to enter default drug Quantity as -1” in Settings -> Sales -> Sale Features

The reason of doing this is there are certain orderables for which the conversion from prescription to quotation cannot be done. The billing person is supposed to look at the quantity in comments and then convert into saleable quantity and then put the right value in quantity column. E.g. Cyclosphamide Injection which comes in saleable unit of 1000mg. If doctor orders 1500mg. The billing person is supposed to look at 1500mg and then put 2 in quantity column and then confirm quotation. Now, as the unit in quotation cannot be left empty, it is defaulted to 1, but there is a risk of billing person confirming the quotation with incorrect quantity. So to mistake proof that, some implementations wanted it to be defaulted to -1 instead of 1. Hence this setting is provided for implementations to have the flexibility.

The code for the logic can be found here :

1 Like