Need help with Making Your First Module

Hi everyone,

I would like to create a custom module and I am following the documentation at but it does not seem to be working would anyone be able to provide a demo youtube video of creating your first module because I am interested in making one but can’t seem to get it to work.

Every time I run the module I keep getting the error: WARN - DispatcherServlet.noHandlerFound(1120) |2018-04-04 22:41:24,051| No mapping found for HTTP request with URI [/openmrs/module/basicexample/basicexample.form] in DispatcherServlet with name ‘openmrs’

Any help would be awesome Thanks

Have you read through this manual

I have checked out that documentation but I have not had any success. I was wondering if you were able to create a module following the documentation and if so would you be able to walk me through on how you did that? I have heard of the possibility of creating modules with OpenMRS Open Web App Module but I have yet to do some research on that yet. I will probably follow up on it soon. and

I would like to create a flu tracker module that could possibly be used to submit data in a specific region this data could later be sent to just something I was interested in doing

yes i managed to create my first module using the steps in as a step to usher me in Dev1. Hope you read the procedures well. The is this clause on the link “See OpenMRS SDK and OpenMRS SDK Step By Step Tutorials.” hope you didn’t ignore it. There are videos on how to create openmrs module just google and download them they are very effective.

From the error message, it seems like you didn’t change some URLs that were copied from the basic module, you probably need to pay extra attention when copying and pasting code to make sure you replace the necessary pieces of code e.g those that contain the module Id.

1 Like

I got this error after I ran mvn openmrs-sdk:create-project then starting mvn clean install openmrs-sdk:run -DserverId=your_server_id_here once the sdk was up and running. I clicked on the module to start and got that error. I got this error before I even started to follow the Making Your First Module example and making any code changes. Is this is what is supposed to happen please let me know Thanks :slightly_smiling_face:

1 Like

Would you be able to share this module code that you made in your github with me because I am working with other students and none of us can get the Making Your First Module documentation to work. Or do you happen to have a working example of that I can look at so I can see how to do it properly?

@shahidfoy Hey! I am part of a team currently working on updating the developer documentation for the GitBook. Since OpenMRS has changed to using Open Web Apps, we are working on changing the Create Your Module documentation. We are not quite done, but are looking to finish by Tuesday ( April 9 2018). One of the things we’re hoping to have is an example that takes you through ever step to build it. If you continue to have problems, you can try and read the documentation we have done. You can do so by following these steps:

Download the code here.
Download and Install Node.js
Install the Node GitBook plugin with the command $ npm install -g gitbook-cli
In the book’s root directory (where book.json is) use the command $ gitbook serve
In your web browser, go to localhost:4000
Select the language English (should be the only option)
You’ll now have access to the page, and can re-download the page whenever to update it.

1 Like

@shahidfoy was your issue sorted out?