My openmrs platform can not start

i had an issue and removed the openmrs war file from tomcat , but now wen i deployed it again in the tomcat’s webappsfolder …it can start. it says

"HTTP Status 404 - /openmrs type Status report

message /openmrs

description The requested resource is not available"

@dkayiwa @k.joseph

try to access the tomcat manager page and manually start it and then post your failure stack trace

1 Like

here is the error log , wen i manually start it.

have u tried to do some googling around; tomcat SEVERE: Parse error in application web.xml?

1 Like

yes i have tried , and all they say is my web.xml file has a problem

theres this warning from tomcat start-up log

WARN - OpenmrsUtil.getRuntimePropertiesFilePathName(2085) |2018-05-02 01:01:29,846| Unable to find a runtime properties file at D:\workspace\eclipse Oxygen\eclipse\ WARN - OpenmrsUtil.getRuntimePropertiesFilePathName(2113) |2018-05-02 01:01:29,848| Unable to find properties file: C:\Users\Dell\Application Data\OpenMRS\openmrs-2.1.3\ WARN - OpenmrsUtil.getRuntimeProperties(2047) |2018-05-02 01:01:29,849| Unable to find a runtime properties file. Initial setup is needed. View the webapp to run the setup wizard. May 02, 2018 1:01:29 AM org.apache.catalina.startup.HostConfig deployDirectory

thats wen i let it to deploy the war file automatically , @k.joseph

@mozzy OpenMRS didnot create a file at startup.

Clear up your cache folders redeploy installation.

1 Like

thx @tendomart, can u please be a bit more detailed on where to find the catche folders? thx bro

because i first deleted the openmrs folder in tomacat , plus the war file, i actually also first deleted the whole tomcat folder , and extracted a new one … i actually droped the whole old openmrs database , hoping to start everything afresh …

so now please help me be more detailed on how to clear up the catche

thx @tendomart and @k.joseph

ive solved that. cheers:grinning :grinning: